cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Twenix
Level: Power Up

Problem uploading DSC config to Azure Automation

Hello, when trying to upload a DSC configuration to Azure Automation, I get the error: GatewayTimeout: The gateway did not receive a response from 'Microsoft.Automation' within the specified time period.. Thanks in advance Christian
1 ACCEPTED SOLUTION

Accepted Solutions
Twenix
Level: Power Up

Re: Problem uploading DSC config to Azure Automation

Hi Kris,

Thank you for your answer.

I uploaded the configuration via web GUI. It was going well several times until the error occured. And then the error came every time.
We don't have an on premises gateway, because I made everything in Azure.

We were just testing Azure Automation as a platform for our configuration management, but meanwhile we decided against Azure Automation (for the time being) because of this problem and data privacy concerns (as I see passwords, that are used in configurations, have to be disclosed to Azure unencrypted; would be nice, if you could give Azure a password that is encrypted via certificate).

Regards
Twenix

View solution in original post

3 REPLIES 3
Highlighted
Community Support Team
Community Support Team

Re: Problem uploading DSC config to Azure Automation

Hi @Twenix,

Could you please share a bit more about your error message?

How do you upload your DSC configuration to Azure Automation?

Please take a try with the resolution within the following article:

https://docs.microsoft.com/en-us/azure/automation/troubleshoot/desired-state-configuration

In addition, there are also some known Issues and Limits with DSC (Desired State Configuration), please check the following article:

https://docs.microsoft.com/en-us/powershell/wmf/5.0/limitation_dsc

More details about importing a DSC configuration to Azure Automation, please check the following article:

https://docs.microsoft.com/en-us/azure/automation/tutorial-configure-servers-desired-state#create-an...

 

You could also consider take a try to re-start your On-premises Data Gateway and clear cache of your browser, then try your operation again, check if the issue is solved.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
TopShelf-MSFT
Level 10

Re: Problem uploading DSC config to Azure Automation

Thank you for posting in the community @Twenix and I'm sorry to hear you're experiencing this problem. Can you review the above reply and advise if it was helpful?

 

@TopShelf-MSFT

Twenix
Level: Power Up

Re: Problem uploading DSC config to Azure Automation

Hi Kris,

Thank you for your answer.

I uploaded the configuration via web GUI. It was going well several times until the error occured. And then the error came every time.
We don't have an on premises gateway, because I made everything in Azure.

We were just testing Azure Automation as a platform for our configuration management, but meanwhile we decided against Azure Automation (for the time being) because of this problem and data privacy concerns (as I see passwords, that are used in configurations, have to be disclosed to Azure unencrypted; would be nice, if you could give Azure a password that is encrypted via certificate).

Regards
Twenix

View solution in original post

Helpful resources

Announcements
thirdimage

New Badges

Check it out!

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

Top Solution Authors
Top Kudoed Authors
Users online (4,657)