cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BenAtDataImprov
Level: Powered On

Problem when exporting an app.

Hi,

I have a fairly complex app that I originally started to build in PowerApps desktop. It uses a Sql Server connection. Now, when I try to share it with another user, it informs me that permission is needed for the Sql connection.

The app was developed in the default environment (originally with the desktop app, later the web studio.) What is weird is that:

  1. Other apps that I developed with the web studio from scratch, all using the same sql connection, can be shared with no extra permission required. They merely asked to Allow use of the Sql, and when Allow is clicked, they work.
  2. I’ve moved these apps to a different environment (not default), and they work fine.
  3. I can NOT move my large app to the new environment because when I try to export it, I get a ‘Could not find connection '0a8512efce047a407a3eb1f9230bbe74' for API 'shared_sql'.
  4. I’ve even tried to export a copy of the large app after removing all data sources, flows, etc., but still get that message.
  5. I’ve even tried to recreate the app from scratch in the new environment , but find that to copy and paste screens doesn’t work as paste doesn’t work consistently – screen elements are not positioned correctly (and yes, my screen sizes match exactly), and some rules simply disappear. It will take too much time, which I just do not have.

Please, please help, getting desperate here!

Ben

 

1 ACCEPTED SOLUTION

Accepted Solutions
BenAtDataImprov
Level: Powered On

Re: Problem when exporting an app.

Ok, the problem that I had has been solved. Thanks to Mallikarjun Maareddy (v-mamaa@microsoft.com) from support for his time and effort - and patience.

 

It's really vety simple: after updating or replacing an app's connection, the app has to be published  BEFORE it can be exported. So it was a sequence-of-events thing.

 

This is currently not documented anywhere though, so I hope it will now be documented somewhere (apart from here).

 

Ben

View solution in original post

2 REPLIES 2
BenAtDataImprov
Level: Powered On

Re: Problem when exporting an app.

Just to summarize, I suppose I'm asking if PowerApps can "remember" an old connection even if no datasources from it are still being used, and what can be done about it.

 

Ben

BenAtDataImprov
Level: Powered On

Re: Problem when exporting an app.

Ok, the problem that I had has been solved. Thanks to Mallikarjun Maareddy (v-mamaa@microsoft.com) from support for his time and effort - and patience.

 

It's really vety simple: after updating or replacing an app's connection, the app has to be published  BEFORE it can be exported. So it was a sequence-of-events thing.

 

This is currently not documented anywhere though, so I hope it will now be documented somewhere (apart from here).

 

Ben

View solution in original post

Helpful resources

Announcements
New Ranks and Rank Icons in April

'New Ranks and Rank Icons in April

Read the announcement for more information!

Better Together’ Contest Finalists Announced!

'Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

thirdimage

Community Summit North America

Innovate, Collaborate, Grow - The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (4,272)