cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Rodrigo1
Helper I
Helper I

Problem with Camera

Hi!

 

I am with problem when with my page that there is camera.. I configurated to take a picture just when I touch on camera  with this code: UpdateContext({Counter: Counter+1}); Collect(CameraPics,({Name:"Report" & Counter & ".jpg",ContentBytes:Camera2_3.Photo, '@odata.type':""}))

 

But my problem is when i change the screen in the app and come back to screen that there is camera, my camera capture one blank picture ..

 

Anyone know why it is happen?

Thanks in advanced,

Rodrigo

 

3 REPLIES 3
v-xida-msft
Community Support
Community Support

Hi @Rodrigo1,

Could you please share a bit more about your issue?

Do you mean that the Camera control captures a blank picture when you navigate back to the screen from another screen?

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned.

The screenshot as below:11.JPG

 

12.JPG

Set the OnSelect property of the Camera control to following:

UpdateContext({Counter: Counter+1}); 
Collect(CameraPics, {Name:"Report" & Counter & ".jpg",ContentBytes:Camera1.Photo, '@odata.type':""})

Set the Items property of the Gallery to following:

CameraPics

Set the Image control within the Gallery to following:

ThisItem.ContentBytes

 

Please check if you have typed the following formula within the OnVisible property of the screen which contains the Camera control:

Select(Camera1)   /* <-- Camera1 represents the Camera control (Camera2_3) in your app */

if yes, please remove above formula from the OnVisible property of the screen which contains the Camera control.

 

If the issue still exists, please consider take a try to re-create a new app on your side, then take a try with above solution, check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi!

I will try to explain more about that.

 

I am create one APP to report about some problem. These screen, there are two option that i would need to complete:

 

First step (Picture name 1):

I would need to complete some question and all questions are visible just when i select "Dados" in top side, because all questions are with formula Visible: !_showDetails 

 

 

Second step (Picture name 2):

After completed the first step, I would need to take a picture and select the best picture in my gallery. For that, i need to change in top side to "Foto", that the options are with formula Visible: _showDetails

 

The problem:

When i change my screen in left side (picture 3) for some where and return to check my screen "Quality Report" (picture 4), in my gallery pops up the "Blank picture" (picture 5).

 

The picture 4 and 5 i will send in other mensage.

 

Do you know why this happen?

 

If you have some questions about that, let me know!

Regards

 

The pictures about the mensage above

 

Regards

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Apps Community Call

Monthly Power Apps Community Call

Did you miss the call?? Check out the Power Apps Community Call here!

secondImage

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Top Kudoed Authors
Users online (79,641)