cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper IV
Helper IV

Problem with a gallery after changing excel to sharepoint

Hi,

I decided to change my data sources from Excel to SharePoint. I created new lists in SharePoint (9 lists) with the same names and values as in excel, and I tried to replace it to the gallery (on the screen).

My gallery is conditional and it depends on a variable, which data source will be used. When I used excel, it found every value easily, but now it can't even find any of my 3 columns (InspectionItem, LastCheck and Frequency) and shows me only InspectionItem column named as 'ThisItem.Title'.

You can see what happened on the screens. Any ideas on how to solve it? I would like the gallery just to find my columns easily.

EDIT: After run I have strange names for not working values, like in pr4 screenshot.

9 REPLIES 9
Helper IV
Helper IV

I just would like to add that everything works fine with a single data source in the gallery, but the gallery is losing data in conditional, multiple sources (made with If(...)'s)

@pal95 
Your Power App is showing errors.  Please take a screenshot and share the message.  Looking at error messages is often the best place to start.

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

Hi,

Here you have:

on pr5 there is the error message

@pal95 
The column 'rdzb' doesn't exist in your new datasource.  Go type in the column name you want to use instead.

Or you need to refresh your datasource.  One of these 2 is the solution here.

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

Unfortunately, none of these is a solution.

1. Refreshing changes nothing
2. If I change that rzdb to 'ThisItem.Frequency' it does not work, it can't find my column called 'Frequency'

@pal95 

Either Freqenuency does not exist as a column, or you added the column and did not refresh the datasource, or its a Choices type column and you need to use ThisItem.Frequency.Value instead.

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up." 

1. It exists in all of 9 lists as a column (see pr6 screen)
2. I refreshed every single data source 5 times
3. not working

The problem appears only when I use multiple data sources. When the gallery items are more than one, so:

If(ValFacility = "Filey", FileyList, 
If(ValFacility = "Flamborough", FlamboroughList))

 It crashes. When I have only a single one, like "FileyList", it works and finds my columns normally.

I did not have this problem when I used Excel. Only in SharePoint, it appears.

up

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Microsoft Ignite

Microsoft Ignite

Join digitally, March 2–4, 2021 to explore new tech that's ready to implement. Experience the keynote in mixed reality through AltspaceVR!

Top Solution Authors
Top Kudoed Authors
Users online (37,197)