cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Helper I
Helper I

Problems with data source after using enhanced SQL preview feature

This week I toggled on the new "Enable enhanced Microsoft SQL Server connector" on my app with two SQL data sources hoping for an improved experience (it did help with a datetime time zone issue) but my app performance started running very poorly (unsure if this is directly related). I have since turned it off. (Note: each time I turn the feature on or off I will remove both SQL data sources then re-add them.)

 

I am now having an issue where I can not get a Gallery to connect to one of my SQL data sources. Even creating an entirely new Gallery just to add this data source to returns and error. What's also strange is PowerApps is even able to preview the head of the data table. 

 

The error returned is:

"The requested operation is invalid. Server Response: An identifier was expected at position 0. inner exception: An identifier was expected at position 0."

2019-10-22_17h47_40.png

 

 

To be clear, since using the preview feature I get this error with the feature turned on or off. I have removed and re-added my data sources each time as well as saved and published. An old save of my app still conencts to this data source without issue. 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Helper I
Helper I

Re: Problems with data source after using enhanced SQL preview feature

Thank you for the reply. I have found what the problem was. I had a different Preview Feature turned on that seemed to be causing the issue.

 

I togged off the "Explicit column selection" and my second SQL data source started working again.

 

What's strange is the performance issues I had noted earlier actually improved after disabling this feature which I believe is intended to help performance. One of my data sources has ~20 columns with 1600 records which is less than desirable but it seems the explicit column selection was making it even worse. 

View solution in original post

2 REPLIES 2
Highlighted
Community Support
Community Support

Re: Problems with data source after using enhanced SQL preview feature

Hi @Brian4 ,

 

Sorry for that, but i can't reproduce this issue, even though I have removed and re-added it several times.

Could you try to remove the SQL connector(not only SQL connection), and re-add it to check if it is fixed? If possible, you even can try it in another app. Also, what does poor performance mean?

The "Enable enhanced Microsoft SQL Server connector" feature is still in Preview, it needs your feedback to improve it.

Best regards,

Sik

Highlighted
Helper I
Helper I

Re: Problems with data source after using enhanced SQL preview feature

Thank you for the reply. I have found what the problem was. I had a different Preview Feature turned on that seemed to be causing the issue.

 

I togged off the "Explicit column selection" and my second SQL data source started working again.

 

What's strange is the performance issues I had noted earlier actually improved after disabling this feature which I believe is intended to help performance. One of my data sources has ~20 columns with 1600 records which is less than desirable but it seems the explicit column selection was making it even worse. 

View solution in original post

Helpful resources

Announcements
Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

August 2020 Community Challenge: Can You Solve These?

August 2020 Community Challenge: Can You Solve These?

We're excited to announce our first cross-community 'Can You Solve These?' challenge!

secondImage

Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

secondImage

Super Users Coming in August

We are excited for the next Super User season.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (6,990)