cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
kriggo15
Post Patron
Post Patron

Published Apps not showing on mobile until viewed on web

We are running into an issue where I can publish an app and share it with someone, but it doesn't show up in PowerApps on their mobile device. It will only show up on their phone when they navigate to the app using the web browser. After they've made that initial web interaction, it will continue to show up even after newer versions are published.

 

Has anyone else experienced this? What causes it and how do I fix it? I can't roll this out to 1000s of users and require them to first access the app via the browser if we are expecting a mobile experience.

1 ACCEPTED SOLUTION

Accepted Solutions
kriggo15
Post Patron
Post Patron

Update: This has been resolved. It was a matter of a severe lag in our environment.

View solution in original post

10 REPLIES 10
goobernoodles
Advocate III
Advocate III

By default, PowerApps shows "My Apps".  Have you changed to "All Apps" and you're still not seeing the apps?  

v-monli-msft
Community Support
Community Support

Hi @kriggo15 ,

 

Please make sure that your user has the latest PowerApps version installed. Is this issue effected to every user in your org? Also, like what @goobernoodles  said,  make sure that your users are selecting the All apps list, not My apps on their mobiles.

 

Regards,

Mona

 

Community Support Team _ Mona Li
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
kriggo15
Post Patron
Post Patron

Update: This has been resolved. It was a matter of a severe lag in our environment.

View solution in original post

Issue still exists on iOS with current version of Power Apps. If user is a guest user in the home tenant, this behavior occurs no matter what. They have to create a bookmark and access the app that way. If they simply login to Power Apps, the shared app never appears in All apps because they are always redirected to their tenant.

 

Please advise ASAP.

crobert8
New Member

Just wanted to add to this post because I found a solution to this issue that isn't mentioned. In my case I had to change the Power Apps Mobile app settings BEFORE logging into the app. There is a small settings cog in the bottom right corner if you are not logged in. I work for a government organization I had to change the location from 'Global' to 'Government GCC', once I did this and logged in the apps showed up.

packnology
Advocate II
Advocate II

Hi, I'm having the same problem with a guest user. They can access the app via web, but when they go to the PowerApps mobile app (on Android in this case) there are no apps under All Apps. They also tried opening the emailed link (auto-sent when the app was shared) and when it opens the PowerApps Mobile it briefly says "switching organizations" and then comes up with an error message that the app can't be found in the tenant. I noticed that the tenant id in the error message is not the tenant the app is being shared from, so probably the "switching org" part failed silently and then it just gave up? Anyone else been able to successfully share apps with guest users on mobile? Any tips would be appreciated. Thanks.

Apps shared from other tenants do not appear in the list of apps for the user, unless they navigated to the app from the link in the email they received when the app was shared with them. I've been fighting with Microsoft on this issue for over a year. We have over 300 Guest users using our apps and this is VERY confusing to them.

 

To make matters worse, there appears to be an issue with the current version of the Android app, where Android users cannot access apps shared with them from other tenants. If you look at the error message generated, you'll notice the app ID GUID is correct, but the tenant ID GUID is the tenant ID for the Guest user's organization, not the tenant ID where the app resides. I'm currently working with MS to address this ASAP but so far, no luck.

Hello,

do you have any update or solution? We're facing the same issue.

BR, Iwo

In my case the reason the app wasn't showing up in the PowerApps mobile app was due to a region setting in the mobile app itself. I had to have users set the region setting after they downloaded the app but before logging in. This only has to be done once as far I have seen, after logging in they then see our apps. May not be the issue with others but figured I'd drop it here because I had never found documentation on this.

Change region setting on power apps mobile app.Change region setting on power apps mobile app.

Helpful resources

Announcements
User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Power Apps Community Call Jan. 2022 768x460.png

Power Apps Community Call

Please join us on Wednesday, January 19th, at 8a PDT. Come and learn from our amazing speakers!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (1,487)