cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ShaqPP
Regular Visitor

Refresh() not working

Hi,

 

When we have a gallery which the Item's property has filter formula, and there is another process to add record in the underlying data source, do we need to do something with the gallery ? 

 

Because in the add record action, I put Refresh(<datasourcename>), it is not effected the gallery, which according to the filter I have put, it should already listed in the gallery.

 

Thanks,

1 ACCEPTED SOLUTION

Accepted Solutions
CNT
Super User
Super User

@ShaqPP If our are having an EditForm and using the SubmitForm function, put the Refresh(<datasourcename>) in the OnSuccess of that Form. It not, how are you adding the record to the DataSource? 

View solution in original post

4 REPLIES 4
StalinPonnusamy
Community Champion
Community Champion

Hi @ShaqPP 

 

Your command should work.

Refresh(DataSourceName)

 Can you validate few things?

  • The Filter criteria whether a new record has correct data to display with this current filter
  • The Sorting order currently have may impact to display on the first batch (100) records
CNT
Super User
Super User

@ShaqPP If our are having an EditForm and using the SubmitForm function, put the Refresh(<datasourcename>) in the OnSuccess of that Form. It not, how are you adding the record to the DataSource? 

View solution in original post

ShaqPP
Regular Visitor

Hi,

 

Thanks, it's works. 😁

@ShaqPP Glad to help!

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,294)