cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Microsoft
Microsoft

Refreshing a data source does not pull in new fields

I extended one of our views to include a few more fields.

PowerApps does not see them.

Refreshing the data source does nothing to expose them.


I think I'm going to have to resort to deleting and recreating the data source.

17 REPLIES 17

Having this issue at this very moment. This is so frustrating. I have been refreshing the datasources but nothing is shown!! 

 

 

Anonymous
Not applicable

Solved: In items modify the Data source and after that put it back to what it was. It will refresh everything in the current table 😄

Can you please provide the exact steps for "In items modify the Data source" please?

Anonymous
Not applicable

You erase some letters in items section and you put them back like before.

This would be a great workaround if it works... But my question was what items section are you mentioning? There are more than one place that deals with databases in PowerApps, can anybody please provide a screenshot of where you make the changes? The changes that I am making do not seem to have any affect....

This is clearly a BUG! And they again just marked this thread as "SOLVED"

Anonymous
Not applicable

- On the left-side menu you got Data sources, click on it.

- Find your data source, click on the triple dot, then click Refresh.

- Click on your Data Table or Form, that use the Data source.

- On right side you got a window with "Advanced" option, click on it.

- {Data Table (1)} In Data section, you got "Items" in this, you got your code.

- {Data Table (2)} Modify the [dbo].[yourdatasource] like: [dbo].[yourdource] and them put it back like before: [dbo].[yourdatasource]

- {Form (1)} Do the same step in {Data Table (1) and (2)}, but in "Data source" and "Item"

- Then Click on "Proprieties" where "Advanced" is.

- Click "Edit fields"

- Now you suppose to have the new fields

I've spent a LONG time on it doing this and that...

It did not work. No matter what I do trying to follow the instructions, it did not work (this *** PowerApps does not see new columns, period).
Could you please provide the instructions only for a Form (Not Data Table), step by step please. If you can include a screenshot: that would be so good! Thanks! : )

I am having the same issue

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Top Solution Authors
Top Kudoed Authors
Users online (92,473)