cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Tman915
Frequent Visitor

Respond To Powerapps Is Returing A String Instead Of A Number

I have two variables that are floats that I am passing into the Respond to a PowerApp action but when I test it out the variables in the respond action turn into strings. I had this issue yesterday and somehow fixed it by clicking add a dynamic variable. I deleted my action and re-added it and can't get it to work again. Here is what I have:

FlowVariables.jpg

 

Flow.jpg

 

As you can see both variable values are floats and the respond action schema has the type to numbers but the result is a string. I find it weird I was able to get it to work yesterday by messing around in the value to respond box but now it won't work.

1 ACCEPTED SOLUTION

Accepted Solutions
Tman915
Frequent Visitor

I figured it out. It must be a bug.

To get it to work I have to click the value box in the respond action, uncheck the "Add dynamic content" button and then re-click it and add the variable.

View solution in original post

6 REPLIES 6
KKDevBox
Frequent Visitor

When returning data from PowerAutomate to PowerApps ensure value returned matches data type.

Power Apps shows blank data when returning number as a string - No errors.

Use expression to convert to data type to match and it works.

Tman915
Frequent Visitor

I converted the value to a float in expression:
FloatVariable.jpg

But I am still getting the same problem. As mentioned in the original post, I was able to get this yesterday by clicking "Add dynamic content" for the value in the respond action (I did this a bunch of times before it worked) but I can't get it now and the values have not changed.

Tman915
Frequent Visitor

I figured it out. It must be a bug.

To get it to work I have to click the value box in the respond action, uncheck the "Add dynamic content" button and then re-click it and add the variable.

View solution in original post

RyanXExner
Advocate II
Advocate II

Banged my head against the wall for hours and finally found your post.  Using an expression to convert to float worked for me, thank you!

I've tried this but can't get it work.  Whatever I do a number is always returned as a string.  It is crazy that this is still an issue.

rschneider
Advocate III
Advocate III

For me, copying the action to clipboard and then reinserting it "updated" both the original and the copy
After creating the respond to app action:

rschneider_0-1629873335350.png

After copying to clipboard and inserting:

rschneider_1-1629873360083.png

 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Microsoft Ignite 768x460.png

Find your focus

Explore the latest tools,training sessions,technical expertise, networking and more.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (1,640)