cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
SalTJX10182018
Advocate I
Advocate I

Rich Text Editor Not displaying text input section

Hi, 

Everytime I add Rich text editor control on the New Form and publish to use that it just display the top bar of the editor but not the text input section. I try to set custom height width, auto height width but nothing is working, one thing that I noticed is I can click on the Expand Toolbar end of the rich text control bar and when I Collpase Toolbar it start displaying small input text section. 

In the Edit form it work fine, load the data fine in the rich text field, only in the New form I have this issue.

 

Thanks,

-Sal

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
tahoon
Power Apps
Power Apps

Hi @SalTJX10182018, this is a known issue. The fix will be deployed within the next 2 weeks.

If you need a workaround in the meantime, try re-setting the desired height of the control when the screen becomes visible.

Set RichTextEditor.Height=TempVariable

In the screen with the editor, set Screen.OnVisible=Set(TempVariable, 10);Set(TempVariable, desiredValue)

View solution in original post

6 REPLIES 6
tahoon
Power Apps
Power Apps

Hi @SalTJX10182018, this is a known issue. The fix will be deployed within the next 2 weeks.

If you need a workaround in the meantime, try re-setting the desired height of the control when the screen becomes visible.

Set RichTextEditor.Height=TempVariable

In the screen with the editor, set Screen.OnVisible=Set(TempVariable, 10);Set(TempVariable, desiredValue)

View solution in original post

Thanks, the workaround worked.

 

-Sal

I will try this workaround, but it doesn't seem this fix was applied in the next two weeks - this is September, 2021, and the problem is still there. Hello, Microsoft? Have you abandoned the Power Platform? Moved on to something else?...

I am also experiencing this issue with my PowerApp that is a custom form for SharePoint editing. the text input on Rich Text Editor sometimes does not show unless you refresh and will only show consistently when on the direct link to edit a specific SharePoint list item, rather than the edit pane that pops in from the right side.

 

The above workaround did not work.

engons
Regular Visitor

Hello,

I am having the same issue, and the workaround does not work. Any other solution?

 

Thanks,

engons
Regular Visitor

Update: the workaround does work, but the thing was that the event "OnVisible" does not run every time I open the form. I put the TempVariable update action at "OnEdit" and "OnView" of the SharePointIntegration object, and that worked. Is this the expected behavior? When is supposed to run the OnVisible event?

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,500)