cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Fouad
Helper II
Helper II

.Run failed: The Run method has an invalid value for the Sendanemail_Body_8 parameter

I'm getting an parameter error when I'm trying to get a Flow ran. Crazy enough this only happens in live stage and not when I'm previewing/editing the form then it does actually sends without any parameter errors.

 

Body_8 means that its refering to my choices column. Does anyone know what to do to get this fixed? The reason I'm trying out HTML in Flow is because when I try to do this in .HTMLText it sends me a default: Show your HTML Text format in my mail.

So I tried it the different way and see if it will do the same when I'm doing it through Flow, hopefully not as I need this to go smooth. Any help is appreciated

form1.PNG

 

form2.PNG

 

3 REPLIES 3
v-siky-msft
Community Support
Community Support

Hi @Fouad ,

 

Can you share more details with issues? Which data source of your app is? Which data type of  datacardvalue1( Reden column) is? Can you confirm that DataCardValue1.Selected.Value is the vaild value in your formula and flow?

I have made a simple test , and don't have the issue you mentioned. I think the cause of issue may be that your flow has ran before the combo box return value after successful submission, if the combo box's item is complex field. So please try to put formulas on the Submit button to check if the issus is fixed.

 

Best regards,

Sik

Hi,

 

Yes DataCardValue1 is a valid value in my formula and flow and it's part of the Reden column. I have also tried the Submit OnSelect button, But this as well give me an error. Data Source all from SharePoint lists form3.png

 

yashag2255
Dual Super User II
Dual Super User II

Hey @Fouad 

 

Based on the last screenshot shared by you, can you try to update your expression in such a way that SubmitForm(Form1) comes after you have set all the variables from the Datacards?
 
Also, if this doesn't help please share more details about the control that is used to passed this variable as SendanEmail_Body_8. Can you try to put Text() function to convert the returned value to be passed as a string?
 
Hope this Helps!

If this reply has answered your question or solved your issue, please mark this question as answered. Answered questions helps users in the future who may have the same issue or question quickly find a resolution via search. If you liked my response, please consider giving it a thumbs up. THANKS!

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Don't miss the call this month on June 16th - 8a PDT

Top Solution Authors
Top Kudoed Authors
Users online (84,337)