cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
lg-power
Helper I
Helper I

SMTP connector Solution import issue

Hi, 

 

I created a SMTP connection reference in my solution that I move around from dev - prod environments. My app and tables are within the same solution. One account's credentials are used to send mails within the app, and this works. In all environments the SMTP connector is shared with the whole organization. 

 

Issue: whenever I move my solution to another environment the app will not be connected to the SMTP connector. This basically breaks my app: app will not start and give the error message "your app was not installed correctly, missing connectionreference". Everytime I move the solution I have to edit the app within the environment it was moved to , re add the connector there, and publish. Creating an unmanaged layer over my managed app layer. 

 

Is moving connectors through solutions bugged out? Never had this issue with e.g. dataverse connector, the Mail connector, AD connector,  sharepoint connectors. 

 

BTW, same behavior I have seen with flows that are added in the dev environment and moved as solution to other environments. 

 

regards, 

 

LG

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
lg-power
Helper I
Helper I

Solved it. It’s quite tricky

 

Best thing to do was start fresh and delete all SMTP connections from target environments. Note this will break the app in these environments temporarily.

Separate the ‘app solution’ and ‘smtp connector solution’ (not sure whether this is actually necessary)

 

Move the app solution first. Move smtp solution after. A screen will appear asking for the properties.

 

App finds the smtp connector now in target environment.

View solution in original post

2 REPLIES 2
lg-power
Helper I
Helper I

Solved it. It’s quite tricky

 

Best thing to do was start fresh and delete all SMTP connections from target environments. Note this will break the app in these environments temporarily.

Separate the ‘app solution’ and ‘smtp connector solution’ (not sure whether this is actually necessary)

 

Move the app solution first. Move smtp solution after. A screen will appear asking for the properties.

 

App finds the smtp connector now in target environment.

View solution in original post

Hello lg-power

 

I have just hit exactly the same problem importing canvas apps that use an SMTP connection.  I've tried to follow your instructions but to no avail....do you mind providing some more info on how you resolved this issue?

 

Many thanks in adcvance

 

Dan

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (2,682)