cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

SQL server connection issue

Good Day 

Over the weekend one of our Powerapps appliactions stopped working we are running Power apps SQL connector through a on premises gateway to SQL Server 2012, the gateway seem to be fine the PowerBI reports runlike nothing has changed. 

When we go to the powerapps web application and test the connection we get an error

"Credentials are missing or not valid. inner exception: Credentials are required to connect to the SQL source." 

but the it was working 5 days ago 

 

The Gateway log says
Non-gateway exception encountered in activity scope: Microsoft.Data.Mashup.MashupCredentialException (0x80004005): Credentials are required to connect to the SQL source.

 

We are using the correct login details into the connector it is like it is not passing them on the the server when trying to connect?

Anyone had this issue or know where to start looking 

35 REPLIES 35
Highlighted
Frequent Visitor

Hi gax700

 

Yes my sql server connection i use is a named instance 

Highlighted
Memorable Member
Memorable Member

I also have named instances.

 

I think the key here is that PowerApps SQL connections do not work while Power BI connections do, I was able to add a connectoin in PowerBI with no issues.

 

Is there a way to get some attention to this post to get a response from Microsoft?

Highlighted

My SQL Server are named instances as well..

Highlighted
Anonymous
Not applicable

We are also experincing the issue. It started for us yesterday afternoon (around 3:00PM MST) We are utilizing a named instance as well.

 

The attempts to connect to the server via PowerAss don't seem to be showing at all in the SQL connection logs.

 

Session ID: 82e4e1a6-bc94-f634-2640-fb2ef8362556

Highlighted

I just noticed in testing again that the Source in the error is adding a second \ in the server name

 

It's showing as:

 

SERVERNAME\\INSTANCE;DATABASE

 

instead of:

 

SERVERNAME\INSTANCE;DATABASE

 

I can't get it to work otherwise, just posting to see if this helps shed some light!

Highlighted

Same exact issue here.  I guess I will stop trying to fix this and wait to hear more...

 

Highlighted

I also haved a named instance here.  

Highlighted

Ditto.  Named instance.

Highlighted

@SinanE can you please take note about this issue that is critical for us? Specially in the apps that we are using for work and are in production environments.

Highlighted

We are treating this as a high priority issue and actively investigating. You can also look at the note at this page https://powerapps.microsoft.com/en-us/support/ , which should have more information once we identify the issue.

 

Thanks.

 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (8,481)