cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
REX
Frequent Visitor

SQL server connection issue

Good Day 

Over the weekend one of our Powerapps appliactions stopped working we are running Power apps SQL connector through a on premises gateway to SQL Server 2012, the gateway seem to be fine the PowerBI reports runlike nothing has changed. 

When we go to the powerapps web application and test the connection we get an error

"Credentials are missing or not valid. inner exception: Credentials are required to connect to the SQL source." 

but the it was working 5 days ago 

 

The Gateway log says
Non-gateway exception encountered in activity scope: Microsoft.Data.Mashup.MashupCredentialException (0x80004005): Credentials are required to connect to the SQL source.

 

We are using the correct login details into the connector it is like it is not passing them on the the server when trying to connect?

Anyone had this issue or know where to start looking 

35 REPLIES 35

The issue should be mitigated now.

View solution in original post

REX
Frequent Visitor

Thanks @SinanE the error see to be fixed 

tbar
Regular Visitor

Fixed.

Brank
Advocate III
Advocate III

Fixed

Anonymous
Not applicable

Thanks!

JRaasumaa
Memorable Member
Memorable Member

Reporting back in from yesterdays outage, all seems to be well, I was able to add SQL connections without any errors this time around.

 

Thanks!

It would be interesting to know what happened.  It's always hard to know how much to reveal about one's internal processes to customers, but this does seem like a pretty big thing (named instances) to have slipped by QC and regression testing.  We've all let things like this slip by, and it's helpful and humanizing sometimes to reveal where the lapse happened and why.

REX
Frequent Visitor

Hi @SinanE

We seem to have an new but simmilar problem now

Invalid Mashup Expression using supplied values. inner exception: An error happened while reading data from the provider: 'Instance failure.'

Please can you check this 

Sandier
Frequent Visitor

I'm facing the same issue right now. 

I had an issue connecting this morning but did a restart of the On-Premise Data Gateway and everything's back up. Might be worth a try?

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Power Apps June 2021

June Power Apps Community Call

Did you miss the call? Check out the recording here!

Top Solution Authors
Top Kudoed Authors
Users online (22,691)