cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
REX
Frequent Visitor

SQL server connection issue

Good Day 

Over the weekend one of our Powerapps appliactions stopped working we are running Power apps SQL connector through a on premises gateway to SQL Server 2012, the gateway seem to be fine the PowerBI reports runlike nothing has changed. 

When we go to the powerapps web application and test the connection we get an error

"Credentials are missing or not valid. inner exception: Credentials are required to connect to the SQL source." 

but the it was working 5 days ago 

 

The Gateway log says
Non-gateway exception encountered in activity scope: Microsoft.Data.Mashup.MashupCredentialException (0x80004005): Credentials are required to connect to the SQL source.

 

We are using the correct login details into the connector it is like it is not passing them on the the server when trying to connect?

Anyone had this issue or know where to start looking 

1 ACCEPTED SOLUTION

Accepted Solutions

The issue should be mitigated now.

View solution in original post

35 REPLIES 35
Brank
Advocate III
Advocate III

Hello can you please give us a solution?  Our applications are stopped because of this.

Anonymous
Not applicable

Have the same issue... asked at monday but there is still no reaktion by anyone.

Anonymous
Not applicable

Have the same issue since Monday... 

JRaasumaa
Memorable Member
Memorable Member

Just lost connectivity to all my SQL sources with On-Premise Gateway as well.

 

No clue if it's a Windows Update that's caused this but it would be nice to have a solution...

And it looks like I'm having the same issue:  Credentials are missing or not valid. inner exception: Credentials are required to connect to the SQL source.  Suddenly happened today.  Working late yesterday.

rfortunato
Regular Visitor

Same problem here

SAME PROBLEM HERE!! SOLUTION NEEDED.

gax700
Frequent Visitor

Same problem here guys...Smiley Sad

 

Just a question: does your SQL server has an named instance? (ie SQLSERVER\INST01)

I've tried to create a connection to a SQL Server with a default instance and it works... bah...

tbar
Regular Visitor

I'm using this: xxx.xxx.xx.xx\PMTLMSSQLDEE01 (x=#). 

No issues until today.

Logged onto server, reinstalled new Gateway update, added existing gateway on server, logged to PowerApp and still has same credential error message.

Helpful resources

Announcements
PA_User Group Leader_768x460.jpg

Manage your user group events

Check out the News & Announcements to learn more.

Power Query PA Forum 768x460.png

Check it out!

Did you know that you can visit the Power Query Forum in Power BI and now Power Apps

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

PowerPlatform 768x460.png

Microsoft Learn

Check out our new Discover Your Career Path blog post series and get all the details.

Users online (1,460)