cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Saved image not showing in gallery

Hi there,

 

Strange thing is happening in my app.

I save images via the Add Picture control in PowerApps to a collection. When I try to view these images in a gallery the images are not showing. When I look in the collection via File - Collection only blobmanager strings are showing.

When I upload the images to Azure Blobs, all images are showing correctly.

 

The add picture code is:

 

Collect(
SIFotoGall,
{
Photo: AddMediaButton1.Media,
Name: DataCardValue1.Text & "image_tab" & "_" & Year(Now()) & Month(Now()) & Day(Now()) & Hour(Now()) & Minute(Now()) & Second(Now()) & Label3.Text & ".jpg"
}
)

 

The collection returns this:

 

look.PNG

 

And in the gallery the save data returns as text items.

 

I am doing something wrong, but i cannot figure it out what.

Any help would be much appreciated.

 

Thanks in advance.

 

1 ACCEPTED SOLUTION

Accepted Solutions
RandyHayes
Super User
Super User

@Anonymous 

Everything that I see on your formula seems correct. 

What is your Image control Image property set to in the Gallery?  If your Gallery items property is set to SIFotoGal, then your Image control in the Gallery template should be ThisItem.Photo

 

 

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
NOTE: My normal response times will be Mon to Fri from 1 PM to 10 PM UTC (and lots of other times too!)
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

View solution in original post

2 REPLIES 2
RandyHayes
Super User
Super User

@Anonymous 

Everything that I see on your formula seems correct. 

What is your Image control Image property set to in the Gallery?  If your Gallery items property is set to SIFotoGal, then your Image control in the Gallery template should be ThisItem.Photo

 

 

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
NOTE: My normal response times will be Mon to Fri from 1 PM to 10 PM UTC (and lots of other times too!)
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!
Anonymous
Not applicable

@RandyHayes 

 

Thank you for your quick answer.

That's the solution. that's what I did wrong!

Helpful resources

Announcements
Super User 2 - 2022 Congratulations 768x460.png

Welcome Super Users

The Super User program for 2022 - Season 2 has kicked off!

Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

<
Users online (3,818)