Showing results for 
Search instead for 
Did you mean: 
Advocate I
Advocate I

Saving a Collection to Sharepoint with numerical coloumns

I have canvas app that collects data for a sharepoint list. To implement offline-caching I have created a colelction that stores the data from the form and uploads it later.

Title: DataCardValue9.Text,
OperatingHours: (Value(DataCardValue10.Text)),
NextInspection: InspectionDate.SelectedDate,
Servicerequired: DataCardValue12.Value,
Reason_x0020_for_x0020_service: ListBox1.SelectedItems,
Comments: DataCardValue14.Text


The text in red is causing issues (it seems) in the save:


If I don't use the "Value" I get a "incompatible type" error, if I use the "Value" I get an error "The specified couloumn "Value" does not exist"...


Any help would be appreciated.


Accepted Solutions

Somehow is missed the notification of your reply.


In the meantime I worked around the problem by changing the sharepoint coloumn to accept TEXT. Now it works... 😕

View solution in original post

Super User
Super User


Hi there!  Your post mentioned some text highlighted in red.  However, I do not see any highlight text.  Could you please reply to this message and share the problematic code line?


Thanks 😄

Sorry for B/W version, I fixed the original post to display the red line. 🙂

Super User
Super User


I am reviewing your code and do not see any errors.  I'd like to ask a few questions.


  • What is the full "incompatible error"?  It usually gives an expected type.
  • When is ItemCache first Collected?  Can you share the code?
  • What value are you inputting into DataCardValue10?  Please also take a screenshot of that input control




@mdevaney  Sorry for the delay and thx for taking time for my problem.


DataCardValue10 is a textfield, but only expects numbers (Annotation 2019-10-15 073503.png). The full error is in ErrorMsg.png. It actually point to the "Collect" method with an underlined "ItemCache" in the Timer event.


ItemCache is initialized in the OnVisible of the StartScreen:



Please show your code for the property in Timer2.OnTimerEnd (screenshot).  In your picture I can see you have an error due to a Text value being supplied.


Also, I find this code to be peculiar.  I am not familar with the technique of initializing a collection with a value of True.  Perhaps you can share more on your coding choice here.  Perhaps loading ItemCache with a single variable here and many columns elsewhere is confusing PowerApps




To clear an existing collection I would typically just use this



Somehow is missed the notification of your reply.


In the meantime I worked around the problem by changing the sharepoint coloumn to accept TEXT. Now it works... 😕

Helpful resources

Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Community Call Conversations

Introducing the Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (5,710)