cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Screen Only Partially Loaded and Stuck (Not Blank Screen nor Loading)

Dear all,

 

This might be the the 5th app I made in PowerApps and this strange behavior only happened 2 months ago and to this app only. This is a simple attendance app where there are basically 3 main screens i.e. Roster Screen, Check-in Screen and Check-out Screen.  All these 3 screens are having the same problem.  Only part of the screen loaded and showed.  In the beginning, 1 out of 5 times was failed to load. Today, I wanted to show this app to someone, it was almost 9 out of 10 were like this.  

P.S. Before going into these 3 screens, there is a Welcome Screen after the App is opened.  And then there is a screen of 3 buttons bring the user into these 3 screens. Both of these screens never have this happening. Therefore, the problem is not from the App loading stage.

 

Every time this happened, I opened the app and kept trying. I did try clear the cache in the IOS device, it didn't help. I did save the app in the web portal and then pushed it to the device.  This partial screen was still happening.  Attached please find the screen supposed to be and the partial screen happened all the times.

 

Below is the code in the On Select of the buttons that jump to the Roster Screen. Since this is still a demo app, the site table only has 10 sites and shift table is about 8 shifts

ClearCollect(colSite,Site);
Set(globalRosterSiteCode,LookUp(colSite,mkDefault="Yes",Title));
ClearCollect(colShift,Shift);
Set(globalRosterShiftCode,First(colShift).Title);
Navigate(RosterScreen,ScreenTransition.Fade,{rosStartOver:true});Clear(tempRoster)

 

Below is the code in On Visible of the Roster Screen

If(rosStartOver,UpdateContext({RosterDateReset:true});UpdateContext({RosterDateReset:false}),"");
If(rosStartOver,Reset(rosTextSearchBox),"");
UpdateContext({rosStartOver:false})

 

There is one thing I notice. If I see a couple little dots (4-5) running across from left to right on the top of the screen, it will load the screen successful. 

 

I hope someone knows what is going on...

 

Eddy

 

 

0 REPLIES 0

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (11,024)