cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Scroll Navigation Arrows of Subgallery not working (App rendering)

Dear community,

 

my app contains a vertical gallery which has horizontal subgalleries. The elements of the subgallery are too many to be displayed at once. Thus, I set ShowNavigation = true in the gallery's properties.

In addition, I am using the pop effect for hovering over the subgallery's elements.

 

When I move my cursor over the navigation arrows, the pop effect causes "shaking" of the element beneath and the arrow itself is not clickable. However, scrolling by pressing Shift and using the scroll wheel works perfectly.

 

The only way I found to "solve" this bug is deactivating the improved rendering.

Please fix this bug so that my app is usable with the new rendering.

 

Kind regards,

Jan

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Power Apps
Power Apps

Re: Scroll Navigation Arrows of Subgallery not working (App rendering)

The original issue has been fixed months ago. You might be experiencing a different issue. If so, please describe in more detail how the gallery is configured and which browsers have this issue.

View solution in original post

7 REPLIES 7
Highlighted
Frequent Visitor

Re: Scroll Navigation Arrows of Subgallery not working (App rendering)

Am I the only one facing this issue?

Highlighted
Anonymous
Not applicable

Re: Scroll Navigation Arrows of Subgallery not working (App rendering)

Facing the same issue

 

We have created an app to display user information from SharePoint list using Vertical Gallery in Power Apps. We enabled the Show Naviagtion option so that the navigation control be enabled on left and right side of the App. It was working fine till few days back. And then we had a requirement to do some minor changes in the app(Font size changes) etc. Post that the navigation control has stopped working(last weekend). Is there some issue with thePowerApp default navigation? Is this functionality is now Absolute? Is there any alternative to the solution.

Any help will be appreciated.

Thanks!

Highlighted
Advocate I
Advocate I

Re: Scroll Navigation Arrows of Subgallery not working (App rendering)

I too have had the same issue in regards to the Navigation scoller not appearing. Works in Chrome but not Edge.

 

Also I have a Dropdown that used to autoselect the first item from a filtered collection - this no longer happens. Not a huge deal but it does change how the user flows through the app and has confused a few of them already.

 

WIll

 

 

Highlighted
Power Apps
Power Apps

Re: Scroll Navigation Arrows of Subgallery not working (App rendering)

This is a known issue with the show navigation buttons. The cause is that the buttons are positioned behind the gallery contents. If the button just happens to be overlapping with other controls, you cannot select it. The workaround now is to set ShowScrollbars to true (which is a good thing for usability anyway).

 

The fix will be coming soon.

Highlighted
Advocate I
Advocate I

Re: Scroll Navigation Arrows of Subgallery not working (App rendering)

Has this been attended to yet? I am still facing the same problem.

Highlighted
Power Apps
Power Apps

Re: Scroll Navigation Arrows of Subgallery not working (App rendering)

The original issue has been fixed months ago. You might be experiencing a different issue. If so, please describe in more detail how the gallery is configured and which browsers have this issue.

View solution in original post

Highlighted
Frequent Visitor

Re: Scroll Navigation Arrows of Subgallery not working (App rendering)

Whole day i was not able to fix this button, solution is so simple that i should not mention how much time i spend to get it.

If in play mode your horizontal gallery  navigation button dosnt work. ( showScroll = false , showNavigation = true ) 

For a quick fix, change your gallery like below.


NavigationStep = If(yourGalleryName.VisibleIndex = 0, 2, 1)

The issue is that gallery cant handle to jump from index 0 to 2 with navigation step = 1.
if you look at galleryVisible index in edit mode, it starts from 1, in play mode from 0... in my opinion it shouldnt be like that.

 

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Come join us today! Find your favorite faces from the community presenting at the Power Platform Community Conference!

Watch Now

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (3,665)