cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
janewald
Frequent Visitor

Scroll Navigation Arrows of Subgallery not working (App rendering)

Dear community,

 

my app contains a vertical gallery which has horizontal subgalleries. The elements of the subgallery are too many to be displayed at once. Thus, I set ShowNavigation = true in the gallery's properties.

In addition, I am using the pop effect for hovering over the subgallery's elements.

 

When I move my cursor over the navigation arrows, the pop effect causes "shaking" of the element beneath and the arrow itself is not clickable. However, scrolling by pressing Shift and using the scroll wheel works perfectly.

 

The only way I found to "solve" this bug is deactivating the improved rendering.

Please fix this bug so that my app is usable with the new rendering.

 

Kind regards,

Jan

1 ACCEPTED SOLUTION

Accepted Solutions
Power Apps
Power Apps

Re: Scroll Navigation Arrows of Subgallery not working (App rendering)

The original issue has been fixed months ago. You might be experiencing a different issue. If so, please describe in more detail how the gallery is configured and which browsers have this issue.

View solution in original post

6 REPLIES 6
janewald
Frequent Visitor

Re: Scroll Navigation Arrows of Subgallery not working (App rendering)

Am I the only one facing this issue?

Anonymous
Not applicable

Re: Scroll Navigation Arrows of Subgallery not working (App rendering)

Facing the same issue

 

We have created an app to display user information from SharePoint list using Vertical Gallery in Power Apps. We enabled the Show Naviagtion option so that the navigation control be enabled on left and right side of the App. It was working fine till few days back. And then we had a requirement to do some minor changes in the app(Font size changes) etc. Post that the navigation control has stopped working(last weekend). Is there some issue with thePowerApp default navigation? Is this functionality is now Absolute? Is there any alternative to the solution.

Any help will be appreciated.

Thanks!

WillEdz Helper I
Helper I

Re: Scroll Navigation Arrows of Subgallery not working (App rendering)

I too have had the same issue in regards to the Navigation scoller not appearing. Works in Chrome but not Edge.

 

Also I have a Dropdown that used to autoselect the first item from a filtered collection - this no longer happens. Not a huge deal but it does change how the user flows through the app and has confused a few of them already.

 

WIll

 

 

Highlighted
Power Apps
Power Apps

Re: Scroll Navigation Arrows of Subgallery not working (App rendering)

This is a known issue with the show navigation buttons. The cause is that the buttons are positioned behind the gallery contents. If the button just happens to be overlapping with other controls, you cannot select it. The workaround now is to set ShowScrollbars to true (which is a good thing for usability anyway).

 

The fix will be coming soon.

cg4life09 Advocate I
Advocate I

Re: Scroll Navigation Arrows of Subgallery not working (App rendering)

Has this been attended to yet? I am still facing the same problem.

Power Apps
Power Apps

Re: Scroll Navigation Arrows of Subgallery not working (App rendering)

The original issue has been fixed months ago. You might be experiencing a different issue. If so, please describe in more detail how the gallery is configured and which browsers have this issue.

View solution in original post

Helpful resources

Announcements
MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Apps Community!

Top Solution Authors
Top Kudoed Authors
Users online (9,544)