cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Search Gallery by Sharepoint People picker field and Lookup Field

Hi,

 

I have a super annoying problem with a people picker field. The properties DisplayField and SearchField keep resetting to ["Claims"] without any obvious reason.

To give some background, the fields are connected to a SP datasource and the appropriate SP column is also a people column. The SP column has access to a internal company list of people with the attributes claims, displayname, email, and department.

I use a combobox as people picker and want to have the displayname displayed and search for the displayname and email.

 

I tried to set the properties in the property column on the right and in the formula bar. Both versions didn't get me a permanent setting. The reset function of the field is not populated so I have no idea why it is resetting in the first place.

There is no action I can pinpoint to the reset, one time I set the properties and saved, closed powerapps and reopened the app and everything was fine. The next time it all went to hell again....

 

Has anybody any ideas or suggestions? What am I missing?

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Hi @Steven_Sm ,

Do you mean that your ComboBox control (which connected to your Person column) is reset to display  ["Claims"] without obvious reason?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. The configuration of my Combobox as below:10.JPG

 

11.JPG

 

Please consider take a try to turn off the "Improved app rendering (final validation)" option within Advanced settings of App settings of your app, then re-load your app, check if the issue is solved.

 

If the issue still exists, please consider re-create a new app, then re-add a new ComboBox within your app, and configure it as above screenshot I provided, check if the issue is fixed.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

8 REPLIES 8
Continued Contributor
Continued Contributor

So it's changing back from the dropdown showing the DisplayName in the values to the Claims text?

You did Unlock the field first, correct?  I don't think this is the issue since you said it changed at least once, but just wanted to ask.

@jhall Thanks for the reply!

It actually changes back without anything being selected or anyone touching the field...

 

The values of the two fields marked in the picture below change back to ["Claims"]. 

Community Support
Community Support

Hi @Steven_Sm ,

Do you mean that your ComboBox control (which connected to your Person column) is reset to display  ["Claims"] without obvious reason?

 

Based on the issue that you mentioned, I have made a test on my side, and don't have the issue that you mentioned. The configuration of my Combobox as below:10.JPG

 

11.JPG

 

Please consider take a try to turn off the "Improved app rendering (final validation)" option within Advanced settings of App settings of your app, then re-load your app, check if the issue is solved.

 

If the issue still exists, please consider re-create a new app, then re-add a new ComboBox within your app, and configure it as above screenshot I provided, check if the issue is fixed.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

View solution in original post

@v-xida-msft Hi,

 

thanks for the help, I deactivated the render feature. The problem you described is accurate. I have the same settings for the combobox connected to a person column. For unknown reasons it resets... sometimes hours after I changed the settings.

I will keep an eye on your suggested solution! If it is still set to DisplayName tomorrow morning, I will let you know!

Hi @Steven_Sm ,

If the issue still exists, please consider clear cache of your browser, then sign in PowerApps again, re-create a new app, then try the ComboBox control again, check if the issue is fixed.

 

If the issue still exists, please consider submit an assisted support ticket throuh the following link:
https://powerapps.microsoft.com/en-us/support/pro

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Hi @Steven_Sm ,

Have you solved your problem?

Is the issue still exists?

 

If you have solved your problem, please go ahead to click "Accept as Solution" to identify this thread has been solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

@v-xida-msft Hi just started the app again, so far it looks good. Clearing the cache and everything else you suggested seemed to have done the trick. Thanks again for the help

@v-xida-msft  

 

Hi, it's me again. I finally figuered out when my combobox "resets" itself. Everytime the Datasource is refreshed, the DisplayField and SearchField reset to the ["Claims"] instead of the wanted ["DisplayName"].

 

This happened also after I followed all of your instructions. Is this a known Issue, hopefully with an easy fix?

 

Helpful resources

Announcements
News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

Power Apps Community Call

Power Apps Community Call- January

Check out the Power Apps Community Call for January 2021

PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

Top Solution Authors
Top Kudoed Authors
Users online (3,614)