cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
ComputerHabit2
Resolver III
Resolver III

SearchUser not finding names

 

I'm using SearchUser in a field. 

ComputerHabit2_0-1638469358460.png

 

When I type in a name it isn't finding people.  It finds a random assortment of users but not the one I'm looking for.  

What is wrong with SearchUser?  Why isn't it looking up names?

If I plug the email address of the user I'm attempting to search for it finds the profile.  If I use try to search in a combo box I don't find it.

 

1 ACCEPTED SOLUTION

Accepted Solutions
RandyHayes
Super User
Super User

@ComputerHabit2 

If that is the formula on your Combobox, then change it to the following:

    Office365Users.SearchUserV2({searchTerm: Self.SearchText}).value

 

I hope this is helpful for you.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

View solution in original post

5 REPLIES 5
gabibalaban
Super User
Super User

@ComputerHabit2 ,

My guess.

Your tenant has by far more than 100 users and by default SearchUser function returns by default the first 100 items. Set the top property of the function to 999 (maximum allowed) and see the results.

Hope it helps !

RandyHayes
Super User
Super User

@ComputerHabit2 

If that is the formula on your Combobox, then change it to the following:

    Office365Users.SearchUserV2({searchTerm: Self.SearchText}).value

 

I hope this is helpful for you.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

View solution in original post

This didn't help.  I'm missing active users from my list.  I know they should be there.  I have thousands of users.  How do I get Search to work?

I think this worked.  Weird thing now is only some selected items get saved.  The results must be missing the mail vaule.

RandyHayes
Super User
Super User

@ComputerHabit2 

Very good.  Saving of selected users is a whole different issue.  That would have to do with how you are saving them and where.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

Helpful resources

Announcements
User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (1,811)