cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Kosenurm
Helper V
Helper V

Security role not starting flows

Hi there,

 

I have a new Security Role set up on PP Admin Center. I am a System Admin. This new security role allows my test user to access the app and perform all functions fine, except starting the Power Automate flows in the app. What could it be in the security role which is missing that I need to enable?

 

The app is a Canvas app, and it (along with the Dataverse tables and all Power Automate flows) are part of a Solution in the correct environment. 

 

Thanks

 

K.

1 ACCEPTED SOLUTION

Accepted Solutions
Mira_Ghaly
Dual Super User II
Dual Super User II

@Kosenurm 

Can you try to set permissions on the Process -> Customization on the security role:

Mira_Ghaly_0-1632025445068.png

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

View solution in original post

5 REPLIES 5
Mira_Ghaly
Dual Super User II
Dual Super User II

@Kosenurm 

Can you try to set permissions on the Process -> Customization on the security role:

Mira_Ghaly_0-1632025445068.png

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

View solution in original post

Thanks, this allowed to flow to be triggered by my test user in that Security Role - thank you so much. 

 

One more thing. The Flow uses the Outlook 365 "Send from a shared mailbox v2" action - the flow didn't run successfully (although it was triggered which is such a relief) as the user doesn't have access to that mailbox.

 

Do I need to add all users to that mailbox so that they can run the triggers from it?   In which case, is it possible to add them so that they can "Send as" that mailbox, but not read?  Is that possible?

 

Many thanks,

K.

Mira_Ghaly
Dual Super User II
Dual Super User II

@Kosenurm 

Can you share the error message on the flow you are receiving on the send email step?

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

"Specified folder not found. The error could potentially be caused by lack of access permissions. Please verify that you have full access to the mailbox."

 

Maybe a Service Account on the AD which is the connection for this action in the flow would be best? 

Mira_Ghaly
Dual Super User II
Dual Super User II

@Kosenurm 

This is weird because the shared mailbox should be accessed by the connection on the step which I believe should not be affected by the running user.

 

So are you sure the current connection user have access?

 

If this post helps you with your problem, please mark your as Accepted solution.If you like my response, please give it a Thumbs Up.

Blog: here

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Microsoft Ignite 768x460.png

Find your focus

Explore the latest tools,training sessions,technical expertise, networking and more.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Welcome Super Users.jpg

Super User Season 2

Congratulations, the new Super User Season 2 for 2021 has started!

Carousel 2021 Release Wave 2 Plan 768x460.jpg

2021 Release Wave 2 Plan

Power Platform release plan for the 2021 release wave 2 describes all new features releasing from October 2021 through March 2022.

Users online (2,966)