cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
New Member

Send HTTP Request to Sharepoint - The expression is not valid

I'm trying to create a simple Send an HTTP request to Sharepoint to update a value in a column.

Here is a sample of my list.

rrogerson_0-1603037423670.png

And here is the very basic flow

rrogerson_1-1603037599018.png

When I test the Flow I get an HTTP 400 error

rrogerson_3-1603037867574.png

 

I've tried to solve this myself by checking other solutions to similar problems but I can't get it to work so I'm asking the community.

 

Thanks,

 

Rob

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Super User III
Super User III

Re: Send HTTP Request to Sharepoint - The expression is not valid

This sounds like a Power Automate question rather than a PowerApps question. I suggest you post this in the Power Automate Community instead. You’ll get a quicker and better response over there

Link to Power Automate Community
https://powerusers.microsoft.com/t5/Get-Help-with-Power-Automate/ct-p/FL_GeneralDiscussions

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

View solution in original post

2 REPLIES 2
Highlighted
Super User III
Super User III

Re: Send HTTP Request to Sharepoint - The expression is not valid

This sounds like a Power Automate question rather than a PowerApps question. I suggest you post this in the Power Automate Community instead. You’ll get a quicker and better response over there

Link to Power Automate Community
https://powerusers.microsoft.com/t5/Get-Help-with-Power-Automate/ct-p/FL_GeneralDiscussions

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

View solution in original post

Highlighted
Solution Supplier
Solution Supplier

Re: Send HTTP Request to Sharepoint - The expression is not valid

Your problem came from URI: 

_api/web/lists/getbytitle('Employee')/items('00010'), where you need to use the SharePoint Item ID and not a column value.

 

Something like this:

_api/web/lists/getbytitle('Employee')/items('1')

 

 

Hope it helps !

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Find your favorite faces from the community presenting at the Power Platform Community Conference!

Watch Now

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (5,730)