cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
omi18
Post Patron
Post Patron

Sending data to SQL Server Using Stored Procedure

Hello,

 

I have the button OnSelect property set to run the following flow. 

 

SetFinal.Run(Gallery1.Selected.ID,TextInput1.Text,DayLoad.Value,Overload.Value,Student.Value,New.Value,From.Value,Approval.Value,Hold.Value,Eligible.Value,Account.Selected.Result,Center.Selected.Result,User().FullName)

 

I'm getting no error on both Powerapps and Automate side. But when I check in the database is shows nothing is updated. 

 

Any suggestions?

 

Thanks,

Omi

1 ACCEPTED SOLUTION

Accepted Solutions
RandyHayes
Super User
Super User

@omi18 

Take a look at the Flow run history and look at the information being passed to your SP.  You should be able to identify if the proper information is being passed to it.  If so, then I would look at your SP to see where the problem might be.

 

I hope this is helpful for you.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

View solution in original post

4 REPLIES 4
RandyHayes
Super User
Super User

@omi18 

Take a look at the Flow run history and look at the information being passed to your SP.  You should be able to identify if the proper information is being passed to it.  If so, then I would look at your SP to see where the problem might be.

 

I hope this is helpful for you.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

View solution in original post

omi18
Post Patron
Post Patron

Hi @RandyHayes ,

 

Right actually there is an error from the database side.

 

Thanks,

Omi

RandyHayes
Super User
Super User

@omi18 

There's where the problem is!

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!
omi18
Post Patron
Post Patron

Hi @RandyHayes ,

 

It is working now. was a small mistake.

 

Thanks,

Omi

Helpful resources

Announcements
User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Power Apps Community Call Jan. 2022 768x460.png

Power Apps Community Call

Please join us on Wednesday, January 19th, at 8a PDT. Come and learn from our amazing speakers!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (1,577)