cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
KevinT
Frequent Visitor

Server Error: 502 BadGateway SQL Direct Query

Dear all,

I'm writing this here because I really don't know what else I can do about that...

We have been using PowerApps in my company for more than a year now, and it worked just fine, but few months ago without any changes in the app or connections, it started to show time to time "Server Error" messages..

Recently, error messages show more details and I can see it's error code 502.
It shows up sometimes on a label, sometimes on a Droplist, sometimes on a Button..

I have seen other posts but they are related to Flows & Sharepoint, and we don't use neither of those.
We have a DirectQuery connection to our SQL Server database, using a Gateway (installed for Power BI but also used for PowerApps. Gateway status = connected, all ok).

This problem is really unconsistant, but I cannot say that this is someting Punctual, as it happens few times a day...

I attach error message from the PC. In this case it's a simple droplist to our SQL server:
Distinct('[DB].[Table]';Name)              (maybe 20 rows max in this table....)

If it persist, we will have to reconsider using PowerApps at all.

Can you please troubleshoot this?

Thank you and best regards;
Kévin

4 REPLIES 4
bhayden
Advocate I
Advocate I

Hello Kevin,

 

We have been getting these issues as well. Still trying to figure out what is causing them.

I will try to update you if I can get some information.

Anonymous
Not applicable

Hi Kevin, 

You can try out the following things: 

1) Check if you are using the recent version of the on-premise gateway if not please download and install it ( remember to use the recovery key). 

2) Stop the on-premise gateway service and start it again. 

3) Sign in to the gateway and check the status. 

 

Hopefully this should resolve the issue. 

 

Thanks, 

Deb

 

RezaDorrani
Dual Super User II
Dual Super User II

Hi @KevinT ,

Try and set a primary key on the sql tables being queried
I had a similar issue and creating a primary key on my table resolved it

Anonymous
Not applicable

Thanks for posting in the community @KevinT - are you still experiencing this issue? Can you review the above replies and update the thread if they were helpful? 

 

Thank you,

 

@Anonymous 

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

PA Community Call

Power Apps Community Call

Next call is happening on April 21st at 8a PST.

MBAS Carousel

Sign up for our May 4th event!

May the fourth be with you, join us online!

secondImage

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Top Solution Authors
Top Kudoed Authors
Users online (20,944)