cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BClouded
Helper IV
Helper IV

Server Response: Contacts Failed: Could not find a property named 'BulkOperation_Logs_Contacts on type Microsoft.Dynamics.CRM.contact

Hi Community
I have a canvas powerapp based on CSD tables. It has always worked perfectly until last week this error pops-up:
Server Response: Contacts Failed: Could not find a property named 'BulkOperation_Logs_Contacts on type Microsoft.Dynamics.CRM.contact

BClouded_0-1618296434218.png

I have no idea where that BulkOperation_logs_contacts comes from, it is nothing I used. 

During some testing I also noticed something weird.
When I do a ClearCollect(collContacts, Contacts), I get quite a lot of columns in my collection I have no clue where they are coming from, see screenshot below.

BClouded_1-1618297702840.png

And further analysing I see it refers to "Quick Campaigns". Does this rings a bell to someone, because to me it doesn't.

Thanks for reading and thinking with me!

Best,
Bart




 

5 REPLIES 5
v-tiribe
Microsoft
Microsoft

Hello @BClouded ,

 

It seems you are facing an intermittent issue when you are retrieving information from CDS. 

In case you refresh the gallery, i believe the data will show as normal but any change made on the Contact gallery will make the error appear again.

 

This is an error that is identified by our Product Group and a solution will be deployed in the future but meanwhile, could you please check if by turning off the Explicit Column selection you are able to see the contact columns without any error?

 

http://powerappsguide.com/blog/post/how-does-the-explicit-column-selection-setting-work 

 

In case you are still facing the issue, try to turn off feature Use non-blocking OnStart rule as well.

 

Best regards,

Tiago Ribeiro | Power Platform Support Engineer

Hi @v-tiribe 

Thank you for your quick response!
The Gallery indeed seems to shows up correctly only once. When you come back to the screen it's gone.
Refreshing the whole app in play mode doesn't bring it back either. You have to manipulate the code a bit in Edit modus the have it function (once).

Disabling that Explicit Column selection option makes the error disappear but the app starts running very slowly. It's quite a big app with +- 20 tables in use. But only the Contacts table give me this error. 

Any indication on when this error will be resolved? Or a link where I can find the status of this problem? 

Thank you
Bart



v-tiribe
Microsoft
Microsoft

Hello @BClouded ,

 

The slowliness you are facing, as i am sure you know, is expected once we disable the Setting at an app level.

 

Regarding your question, we do not have any link publicly available to follow the scenario. 

My suggestion is for you to create a service request on portal https://admin.powerplatform.microsoft.com so that we can provide you with more information about this problem.

 

Best regards,

Tiago Ribeiro | Power Platform Support Enginner

dee2005
Advocate III
Advocate III

I'm also having this problem since last week and also on the contacts table. What changed???

 

@BClouded did you create a service request? Any progress there?

Hello @BClouded  and @dee2005 , 

 

The issue was fixed on May 5th, so we are not expecting you are facing the issue at the moment. 

Please make sure you do a modification on the app, and publish a new version. 

 

Best regards,

Ana Almeida | Power Platform Support Engineer

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Top Solution Authors
Top Kudoed Authors
Users online (1,233)