Showing results for 
Search instead for 
Did you mean: 
Not applicable

Server Response ETAG mismatch (Conflicts exist with changes on the server, please reload)

I've been having this error since last week and it was working fine before. 


I can't update my SharePoint list when I press the "Yes", ETAG error appears.


It happens when I update/select/choose a Leave Type and patch the LeaveTypeList Column on the LeavDateSourceSelected.

Same thing happens when I update the Approver Column.


I'm not sure if PA has to do with it or a SharePoint error.


Any idea will be helpful. 




Accepted Solutions
Not applicable

Fixed the problem!


I inserted the Refresh(DataSource) Function before the final patch.


On "Yes" Button:


UpdateContext({ showLoader: true});
Refresh(LeaveForm); I added this.
Patch(LeaveForm , LeaveDataSourceSelected,
LeaveTypeList: NewLeaveTypeList,
Approver: EditRequestItem.Approver,



On "Save" Button:


UpdateIf(LeaveRequestSelectedCollect ,LeaveTypeList <> EditLeaveTypeGallery.Selected.type, {LeaveTypeList:EditLeaveTypeGallery.Selected.type});


Instead of using Patch on the "Save Button" I used UpdateIf Function.


After changing the codes. Save and close your application and Open it again.



View solution in original post

Community Support
Community Support

Hi @Anonymous,


Could you please share a bit more about your app's configuration?

Could you please show a bit more about the LeaveForm and LeaveRequestSelectedCollect that you mentioned?

Further, when do you trigger the Save button within your app?


The error message seems to tell that there is a conflict error existed between the "Yes" button ("Yes" button code) and the "Save" button ("Save" button code) within your app.


I think you have faced ETag HTTP response issue within your app. More details about the ETag HTTP response, please check the following article:


The ETag is a part of HTTP, it could be used for optimistic concurrency control as a way to help prevent ghost writes. Please check the following article for more details:


In addition, please consider take a try to remove the code within the OnSelect property of the "Save" button, then try your "Yes" button again to check if the issue is solved.


Best regards,



Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Not applicable

This is a video of the ETAG error:


LeaveForm is a SharePoint List with LeaveTypeList as a Singe Line Text Column.

I am seeing the same issue - SharePoint list


Here is the pattern



I republished the app and an item will save fine on the first edit and save but you will get this the second time you edit and try to save.


This is very consistant an easy to reproduce. 


Open item and edit and save - no problem.  Open another list item and save - no problem.  Go back to first item and try and save - you get the error.  Go to the second item that you edited and try and edit and you get he same error



So here is the pattern

Open an item and save - works fine.   Open the saved item and edit and try and save - you get the error.

Not applicable

@skylitedave, Yes that is exactly what is happening with my app which is weird. I'm pretty sure it has something to do with the update in PA or SharePoint at this point.

I've been trying to solve the issue but nothing works. I even tried to recreate the list and connect it as a new data source but the same error occurs. 


Any suggestions on how to fix this would be greatly appreciated.


So you see the same pattern - right


Edit first time and save - no problem


Try and edit second time and you get the error - right?


SharePoint list is the datasource - right?


Please confirm all of this so the powerapps team can dig in

Not applicable

Yes, that is what is happening.


I see the same pattern - TRUE


Edit first time and save - TRUE


Try and edit second time and you get the error - TRUE


SharePoint list is the datasource - TRUE



I just confirmed this pattern with a form associated with a SharePoint list using Modern lists as well..


Issue is in the WebPlayer and webstudio

This issue is SESSION based...


If you close the app and reopen then you can save the item the first time you edit but you will always get the error the 2nd time and beyond during that session....

Not applicable

Let's say I published and rolled out the application and one user wants to edit entry multiple times in one session then the error will appear everytime? It's not ideal.


I used to edit an entry multiple times in one session 2 weeks ago without any issue. 


Can you provide an alternative you have in mind? a workaround perhaps?

Helpful resources

Power Apps News & Annoucements carousel

Power Apps News & Announcements

Keep up to date with current events and community announcements in the Power Apps community.

Community Call Conversations

Introducing the Community Calls Conversations

A great place where you can stay up to date with community calls and interact with the speakers.

Power Apps Community Blog Carousel

Power Apps Community Blog

Check out the latest Community Blog from the community!

Top Solution Authors
Top Kudoed Authors
Users online (6,084)