cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
NigelP
Kudo Kingpin
Kudo Kingpin

Server Response ETAG mismatch (Conflicts exist with changes on the server, please reload)

Hi

 

I am getting the dreaded ETAG error message when I submit my form and perform a patch on the record.  Here is the OnSelect code :-

 

SubmitForm(EditSubmissionsForm1);If(numattachments > 0,ClearCollect(Attachments,SubmissionsForaMeetingGallery.Selected.'{Attachments}'.DisplayName);

ClearCollect(AttachmentsUri,SubmissionsForaMeetingGallery.Selected.'{Attachments}'.AbsoluteUri);

UploadafiletoSharePointfromPowerApps.Run(First(Attachments).DisplayName,First(AttachmentsUri).AbsoluteUri,"/Shared Documents/"  &  PRJIDComboBox.Selected.PRJ_x002d_ID & "/" & SubmittedGateNumber.Selected.Value));

Patch(Submissions,

{ID:EditSubmissionsForm1.LastSubmit.ID},

{Assurance_x002d_Status:{

    Value: "With Assurance",

    '@odata.type': "#Microsoft.Azure.Connectors.SharePoint.SPListExpandedReference"}

}

)

 

This only occurs occasionally and if I remove the PAtch statement - not at all.

 

Any Ideas ?

 

Regards

 

Nigel

28 REPLIES 28

Try a Refresh before you submit the Patch

Hi @skylitedave

 

I will try a Refresh of the List before I patch it.

 

Thanks

 

Nigel

Please see this thread

 

Problem is described and confirmed in detail along with a workaround

 

https://powerusers.microsoft.com/t5/General-Discussion/Server-Response-ETAG-mismatch-Conflicts-exist...

 

 

Hi @skylitedave

 

Thanks for the post.

 

I have put a Refresh before the Patch and so far so good.

 

Lets see what it is like when the system is under load tomorrow.

 

Regards

 

Nigel

Any update on a fix???  This is a wicked bug

Hi @skylitedave No reports of any problems today,. So looking good for the workaround. Regards Nigel

Any update...  this is being mentioned in at least 2 threads and has been open for at least a week...

 

How about confirmation that you can reproduce the reported issue as step 1?

v-xida-msft
Community Support
Community Support

Hi @NigelP,

 

Just an update -- A hotfix for the ETAG Mismatch issue is included in version 3.18073 which will be available in the upcoming week.

 

More details about the progress of the ETag mismatch issue, please check it within the PowerApps Support page:

https://powerapps.microsoft.com/en-us/support/

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

Does anybody Managed to fix this problem ?

 

I tried refreshing data source before Patch in Vain

Hi @MiraGhaly

 

This was fixed a couple of months ago and has been working ever since.

 

If you still have a problem, I suspect it is something else, like someone else has updated the record between now and when you last saved it.

 

Regards

 

Nigel

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

MBAS Attendee Badge

Claim Your Badge & Digital Swag!

Check out how to claim yours today!

secondImage

Are Your Ready?

Test your skills now with the Cloud Skill Challenge.

secondImage

Demo Extravaganza is Back!

We are excited to announce that Demo Extravaganza for 2021 has started!

MBAS on Demand

Microsoft Business Applications Summit sessions

On-demand access to all the great content presented by the product teams and community members! #MSBizAppsSummit #CommunityRocks

Top Solution Authors
Top Kudoed Authors
Users online (43,837)