cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Mangeshmm
New Member

Server side RLS not working with PowerApps

Hello All - I am facing a vexing problem which I seek help on.  Essentially, the server side RLS does not seem to work with PowerApps.  I have a table in Azure SQL PaaS and 3 AD groups (say AD1, AD2 and AD3) - each AD group has a distinct set of users.  The AD groups have been added to the database as users (using CREATE USER [AD1 etc] AS EXTERNAL USER) - I am using SSMS to access and test the database.  The same groups have been added to PowerApps to grant access to an app.  I have added the required Filter predicate and Security Policy for a server side RLS.  Using SSMS and logging in as different users into SSMS, I can confirm that the RLS is correctly and consistently filtering rows as desired.

 

Now the problem

 

When I go PowerApps, it shows all the rows for all the user groups (essentially it is not filtering the relevant rows for AD1, AD2 and AD3).  I am genuinely puzzled at the error - if anything, it should show zero rows - however, it is showing all the rows without any filtering and hence does not respect the filter predicate.

 

Please help me why a server side RLS does not seem to work in PowerApps.

0 REPLIES 0

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

365 EduCon 768x460.png

Microsoft 365 EduCon

Join us for two optional days of workshops and a 3-day conference, you can choose from over 130 sessions in multiple tracks and 25 workshops.

Users online (1,560)