cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Advocate II
Advocate II

SharePoint Custom Form does not load

Hello,

 

I've just deployed a new process in beta at my office, which includes a SharePoint list and a PowerApp as a custom form.

 

The issue I have is that if the user refreshes the page, the form wont load until I make a minor change (usually I just add some notes on the OnStart property of how annoying this is) and publish those changes. But... if they refresh the list then I have to go through this again. This error will happen in both IE and Chrome.

 

I can't sit in their area and re-publish the app multiple times a day. They'll need to refresh their view to make sure that tasks they've worked that day are filtered out. I've seen a few places where the solution was to delete the application and recreate it from scratch but it is not an option with how long it took me to make it in the first place - it is highly customized.

Please let me know what I can do so that this solution will actually work.

8 REPLIES 8
Highlighted
Community Support
Community Support

Re: SharePoint Custom Form does not load

Hi @RTW ,

Currently, there are some issue with Custom form functionality in SP Online List. The user @kevingeorget has faced similar issue with you, please check the following thread:

https://powerusers.microsoft.com/t5/Building-Power-Apps-Formerly/PowerApps-pulling-old-record/td-p/4...

 

I have posted this issue to my product team, if this issue is solved, I would reply here.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Advocate II
Advocate II

Re: SharePoint Custom Form does not load

@v-xida-msft , that doesn't quite look like what I am experiencing. The looks similar to this one.

 

https://powerusers.microsoft.com/t5/Building-Power-Apps-Formerly/PowerApps-custom-form-not-loading/t...

 

I submitted a case (119111224004658) with Microsoft Support yesterday as well, if that is useful.

 

I checked the console in Chrome while experiencing the error. When I tried to load the app I got the following message "player.js:1 AppLoadedEvent Timeout Expired ... Flushing Telemetry" and nothing else would happen. Logs from a case where it was successful show what looks like some authorization information before the app loads.

 

Please let me know ASAP what can be done. I have to delay the launch of an important project because of this.

Highlighted
Community Support
Community Support

Re: SharePoint Custom Form does not load

Hi @RTW ,

Do you mean that the Custom form in your SP list could not load correctly?

Have you take a try to edit your custom form app (made some changes), and re-publish it again?

 

On your side, please consider clear cache of your Browser, then sign in your SP List again, check if the issue is solved. Also please consider edit your custom form app, and made some changes to it, and then re-publish it again, check if the issue is fixed.

 

Currently, there are some known issue with Custom forms functionality in SP List (just as I mentioned in above thread), I have posted this issue already. I think your issue may be affected by this known issue.

Please consider edit your custom form app using previous PowerApps Studio as below:

https://create.powerapps.com/v3.19104.33.130671691/studio/#action=sp-edit-formdata&app-id=<your-app-... 

then made some changes to it, re-publish it again, check if the issue is solved.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Community Support
Community Support

Re: SharePoint Custom Form does not load

Hi @RTW ,

This issue has been fixed, please take a try with it on your side, check if the issue is solved.

 

If you have solved your problem, please consider go ahead to click "Accept as Solution" to identify this thread has been solved. If the issue still exists, please consider remove the custom form, then re-customize a new one in your SP List, check if the issue is fixed.

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Highlighted
Advocate II
Advocate II

Re: SharePoint Custom Form does not load

@v-xida-msft I'm not sure if I should mark this as solved as I ended up re-creating it as a canvass application and deleted the custom form.

Highlighted
New Member

Re: SharePoint Custom Form does not load

I'm facing the exact problem... 😞

Any news on this ?

Is the only solution to convert to canvas app?

 

 

Highlighted
Helper II
Helper II

Re: SharePoint Custom Form does not load

Also getting the same issue. Can create a new item from IE but not from Chrome. Forms just tries to load (running circle). Any ideas Microsoft ?

 

Form has been working for months, now all of a sudden we are getting this problem ?

Highlighted
Helper I
Helper I

Re: SharePoint Custom Form does not load

Hello Guys, 

 

We opened up a ticket directly with Microsoft and this is what we got - apparently it works with IE for now.. until further notice.

=============

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

Watch Now

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV Studio

Power Platform ISV Studio

ISV Studio is designed to become the go-to Power Platform destination for ISV’s to monitor & manage published applications.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (7,642)