cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Bhavpreet
Advocate I
Advocate I

SharePoint Custom Forms cutting out from end

Hello,

 

I have a custom SharePoint form built using Powerapps in landscape orientation (1185x790). The forms opens normally when opened from an item. However, when the form link is copied and opened using the link in a new tab, the bottom part cuts out. The form can scroll only as much on the page. Part of the form stays below the screen. It can be accessed by zooming out the page but not otherwise. Is there a way to have the form scaled to page height or some other way to resolve the issue?

 

Thank you,

Bhavpreet Bains

11 REPLIES 11
MarvinBangert
Solution Sage
Solution Sage

Hey @Bhavpreet 

can you share a screenshot of what the issue looks like within your SharePoint?

Do you use a canvas app (started from Power Apps - New App - Canvas App) or do you use a SharePoint customized form (started from SharePoint - Power Apps - Customize forms)?

If you use a canvas app, under "File" - "Settings" - "Screen size + orientation" you will see some advanced settings on how to app fits within the screen.

Image 622.png

These options are not available in a SharePoint Power Apps customized form.

 

Regards

Marvin

Hello Marvin,

I am using Customized form. 

This is how the form looks like scrolled all the way down:

PowerAppsFormIssue.png

This is how it should like:

PowerAppsForm.png

I am not sure how to fix the issue.

Thank you.

Hey @Bhavpreet 

thanks for your answer, so it looks like your app hides behind the windows taskbar. Do you use the Windows 10 functionality to automatically hide the taskbar? Then your browser screen fills all of your screen and if you hover over the taskbar, it hovers over the browser too. Have you tried another browser or another laptop?

 

Thanks in advance

 

Regards

Marvin

The browser window is open till task bar. Autohide task bar is not being used. The issue is reproducible with different browsers.

My feeling is on opening the file in a new tab it adds additional static items on top. Considering the screen size of the form staying same, creates the partial powerapps form window beyond the browser size. The browser does not recognize the same and does not provide the scroll causing the issue.

 

The custom form in new tab with static items:

PowerAppsFormIssue.png

The custom form opened from the item in the list window:PowerAppsForm.png

Max44
Helper V
Helper V

I've run into problems with the 'hillbilly' style code where rich text fields didn't populate correctly. Going into an EditPage wouldn't show the data. I had to change the fields from rich text to enhanced rich text (these were from a list created in SharePoint 2010). I never found out the underlying reason - it seemed to be some kind of timing issue but never really gave a hard answer.

When you're running through your JQuery, when you are getting the original field, make sure it doesn't pick up multiple values - you know, the problem when you look for 'Description' and you've got 3 columns that use that text. You might need something like this:

    //find the corresponding field from the default form and move it
    //into the custom layout
    // we have multiple fields with 'description' in the name
    // also Completed By    x = (displayName=='Description'? 1: 0);    x = (displayName=='Completed By'? 1: x)    x = (displayName=='Scan Requested'? 1 : x)    thiscontent = $("nobr:contains('" + displayName + "')").eq(x).parents('tr:first').find('td').eq(1).contents();

Also, there's css in there to hide the original table structure - maybe while you are debugging remove the style

   .ms-formtable
  {display:none;}

and see if your missing fields are still down there. If they are, then the move didn't work.

 

Admin

O365cloudexperts

I'm having the same issue, except mine goes to the left and I can't scroll over to it. I am also using a link, instead of the original list, to start a new item. Please post if you get this figured out. Thanks.

Hello Jessica,

 

I have logged a ticket with MS to get it resolved. It might take some time to get it fixed.

Jill1
Regular Visitor

I am also experiencing this issue.

 

The app is cut off at the top and cut off at the bottom, and you have to scroll to the right on mobile. This is occurring when using the Link to List item link from an email automatically generated from Power Automate, so not occurring if you open the item directly from the list, just when you use a link to open the item.

 

In my case, I am using portrait mode. No size customizations. I just used the Customize in Power Apps link from SharePoint to generate the custom form in Power Apps.

may be if everyone will log a ticket, hopefully MS will address the problem sooner. A quick workaround that I've been using is adding extra space by adding an empty data card at the bottom. However if you have a date picker used, it will always load the ok and cancel below the screen. 

Helpful resources

Announcements
UG GA Amplification 768x460.png

Launching new user group features

Learn how to create your own user groups today!

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

M365 768x460.jpg

Microsoft 365 Collaboration Conference | December 7–9, 2021

Join us, in-person, December 7–9 in Las Vegas, for the largest gathering of the Microsoft community in the world.

Top Solution Authors
Top Kudoed Authors
Users online (1,455)