cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Helper I
Helper I

SharePoint Customized Power App Form

One column out of 12 columns of metadata in my sharepoint library is not showing up when my flow moves the document to another sharepoint library. I'm using a customized power apps form. All my column names match, their all the same. Does anyone know why the column data is not showing up when its moved? I've checked my flow and its grabbing the meta data its just not showing up in the column.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Dual Super User II
Dual Super User II

Re: SharePoint Customized Power App Form

Is the column a site column or just a column added to the list?  Just because the column name is the same doesn't mean its the same column in both lists.  When you create a column it uses a GUID to identify the column.  If you just add the column to two different lists then the columns will have different GUIDs.  But if you create a Site Column and add it to both lists then it will have the same GUID. I suspect that is why the column isn't being duplicated correctly by your form.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

5 REPLIES 5
Highlighted
Dual Super User II
Dual Super User II

Re: SharePoint Customized Power App Form

Is the column a site column or just a column added to the list?  Just because the column name is the same doesn't mean its the same column in both lists.  When you create a column it uses a GUID to identify the column.  If you just add the column to two different lists then the columns will have different GUIDs.  But if you create a Site Column and add it to both lists then it will have the same GUID. I suspect that is why the column isn't being duplicated correctly by your form.



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.

View solution in original post

Highlighted
Helper I
Helper I

Re: SharePoint Customized Power App Form

Its a column I added to a SharePoint library and I added 9 columns and only one does not show up when the document moves to another library. All the rest of the column data moves fine to the next library. 

Highlighted
Helper I
Helper I

Re: SharePoint Customized Power App Form

@Pstork1 should my other libraries just be look up columns, is that what your saying?

Highlighted
Dual Super User II
Dual Super User II

Re: SharePoint Customized Power App Form

No, I'm saying the libraries should be using the same content types made up of the same set of site columns.  Can you show me the schemas of the two libraries and which column doesn't sync?



-------------------------------------------------------------------------
If I have answered your question, please mark your post as Solved.
If you like my response, please give it a Thumbs Up.
Highlighted
Helper I
Helper I

Re: SharePoint Customized Power App Form

@Pstork1 your right, I done what you said and it works beautifully. Thank you for your help!

Helpful resources

Announcements
secondImage

New Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

August 2020 CYST Challenge

Check out the winners of the recent 'Can You Solve These?' community challenge!

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Users online (4,939)