cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Cbeene
Level: Powered On

SharePoint List Custom Form - Multiple Errors

PA Community, I need your HELP.  I have a SharePoint list that I am attempting to build a custom form for.  For some reason every card has an error message.  In test runs the People Picker and Choice fields don't work, leading me to believe the issue is not at the card level but the overall form level.  In the image attached you can see that the Choice field I am hovered over is stating the Choice field "Has some invalid arguments".  Looking at the "Items" entry on the right shows where the field should be pointed to (Choices('Production Disposition Process'.Reason_x0020_For_x0020_Submissio)).  This is the correct format but doesn't work here.  

To test, I have exported this list as a template and created several versions of it.  In some cases, the PowerApps form looks like this and doesn't work, in other cases there is no error and it works fine.  

1 ACCEPTED SOLUTION

Accepted Solutions
Cbeene
Level: Powered On

Re: SharePoint List Custom Form - Multiple Errors

@RandyHayes 

Sorry to lead you astray with the extra infomraiton.  

1) I don't believe my Datasource has issues. When I refresh it from within the app, it doesn't throw any errors.

2) I have removed and re-added the data source.  Just now as a matter of fact AND refreshed again with no issues.  

3) I swear I have "inserted a new screen in your app and insert a new EditForm" without success in the past based on your suggestion, but this time it worked.  I now do NOT have errors in my form.  

4) Permissions shouldn't be an issue.

 

So, it appears that I am all set now, but don't understand why, which makes me nervous too.  I'll take the win however.  T

Thanks for the assist Randy

View solution in original post

24 REPLIES 24
Super User
Super User

Re: SharePoint List Custom Form - Multiple Errors

@Cbeene 

You are most likely having an issue at the form level, not the individual columns.

1) What is the DataSource property on the form set to?  It should be the name of the SharePoint List.

2) What is your Item property on the form set to?  It should be set to SharePointIntegration.Selected 

 

Also, view your data sources to make sure you are not experiencing any errors there.

 

I hope this is helpful and leads to a solution or another clue.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Cbeene
Level: Powered On

Re: SharePoint List Custom Form - Multiple Errors

@RandyHayes - Thanks for the reply.  The DateSource properites appear to be correct.  How do I check the Item Properties for the form itself?

Super User
Super User

Re: SharePoint List Custom Form - Multiple Errors

@Cbeene 

Click on the Form (easiest in the tree list on the left), then choose the Item property in the property dropdown in the formula bar.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Cbeene
Level: Powered On

Re: SharePoint List Custom Form - Multiple Errors

In both versions of my test forms (one works, one doesn't) and in my actual form the Item and DataSource properties match and/or are correct. Thanks though.

Super User
Super User

Re: SharePoint List Custom Form - Multiple Errors

@Cbeene 

A couple other options to try:

 

1) Create a new screen and add a new EditForm there with the datasource and Item properties the same.  If you still have errors at that point on the new form, then there is an issue with the DataSource and/or Connection in the App itself.

2) If there are no errors on the new screen and new form, then go back to the other screen and select the form, then ctrl-x is (cut), then ctrl-z (undo).  Many times removing a control from PowerApps that has errors and then forcing it back in with an undo, will reinitialize the form and clear up all the issues.

 

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Cbeene
Level: Powered On

Re: SharePoint List Custom Form - Multiple Errors

@RandyHayes - The new form has the same errors so I would assume it is the Datasource and/or connection in the App.  Any Idea how to trouble shoot that?

Super User
Super User

Re: SharePoint List Custom Form - Multiple Errors

@Cbeene 

Let's just recap here a bit in a check list to make sure you've covered all the bases:

Working from the tree list -

Cbeene.png

- SharePointIntegration

   1) DataSource property is set to your SharePoint List?

 

- On your form screen and the SharePointForm

   1) DataSource property is set to your SharePoint List?

   2) Item property has a formula in it that refers to SharePointIntegration.Selected?

 

- In your DataSources (View-Data sources),

   1) You see your data source listed there and there do not appear to be issues with it (errors, warning icons, etc.)?

   2) You can choose the ... menu next to the datasource and click refresh and all is successful to do a refresh?

 

Check all of the above and let me know if any are not happening or displaying information as noted.

Also, hover over one of the red X's (preferably the very top one) and let me know what the error is that is reported.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Cbeene
Level: Powered On

Re: SharePoint List Custom Form - Multiple Errors

@RandyHayes  Doubled checked and I am a yes on all 5 items.

As far as error messages - 

On a Single Line text box I see:

Capture.JPG

 

On a Choice field I get:

Capture1.JPG

 

 

Super User
Super User

Re: SharePoint List Custom Form - Multiple Errors

@Cbeene 

Hmmm...going for the bigger guns now...

 

Go into your datasources list (View-Data sources) and remove the datasource to your SharePoint list. Then click on the add data source and choose your SharePoint connector and then the SharePoint list to add it back in.

You might also want to then delete and undo (as I described earlier) the entire form once you've added the data source back in.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.

Helpful resources

Announcements
thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Power Platform World Tour

Find out where you can attend!

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

SecondImage

Difinity Conference

The largest Power BI, Power Platform, and Data conference in New Zealand

Top Solution Authors
Top Kudoed Authors (Last 30 Days)
Users online (5,488)