cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Community Support
Community Support

Re: SharePoint List Custom Form - Multiple Errors

Hi @Cbeene ,

Could you please share a bit more about the issue?

 

Based on the screenshot that you mentioned, I think there is something wrong with the SP List connection within the custom form app.

 

Please check if you have changed some columns in your SP list. Please consider remove the SP list connection from this custom form app, then re-add a new connection to the SP List from the custom form app, then try it again, check if the issue is solved.

 

If the issue still exists, please consider remove the custom form from your SP list, then re-add a new one, then check if the issue still exists.

More details about removing custom form from a SP list, please check the following article:

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/customize-list-form#delete-the-custom-f...

 

Best regards,

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Cbeene Helper I
Helper I

Re: SharePoint List Custom Form - Multiple Errors

Thanks for the suggestions but I have already tried these things. Specifically, I deleted the connection entirely, created a new one and connected it to the list. I have also deleted the custom form and created a new one several times.

 

When you mention "Please check if you have changed some columns in your SP list" however it got me thinking. I haven't changed any column headings since creating the custom form but may have changed some before the form was ever built. Would that effect the PA form?

Cbeene Helper I
Helper I

Re: SharePoint List Custom Form - Multiple Errors

Here is a bit more data that may shed some light on this for you more experienced users.  As I said, I create a template from my original list and created test lists from said template.  In some cases, the custom form was erroneous, in other cases it was not.  When I look at the DataCardValue "Item" property, the match (see below).  In the one that works I have data written in the DisplayFields and SearchFields propery.  In the one that works, I do not.  

Capture.JPG

Capture1.JPG

Super User
Super User

Re: SharePoint List Custom Form - Multiple Errors

@Cbeene 

Yes, what you are seeing in the combobox is normal.  It is unable to resolve anything about your datasource and thus those will be blank.  That is not your issue.  The issue is outside of your datacards.  It is at the form level or beyond into the datasource. 

But, your description of your actions may lead to a clue - you mention you created a template and then a list from that template.  Can you describe those steps a little further?  Are you referring to a SharePoint template or something else?  

 

 

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Cbeene Helper I
Helper I

Re: SharePoint List Custom Form - Multiple Errors

@RandyHayes -

to be clear, my original list that I am having an issue with was created in SP from the standard "Add an App>List" function. 

As a test I "exported as a template" in SharePoint, download the STP file from the template gallery, navigated to the Test Site and uploaded the template there.  I then created two test list ("Production Disposition Process" and "Production Disposition Processs" (note the extra "s" in the second one)).  The first test list has an erroneous PA form (just like the original master list) and the second does not.  Does that shed light?

Super User
Super User

Re: SharePoint List Custom Form - Multiple Errors

@Cbeene 

A little more light is coming on...

So, let me fill in a couple blanks with some assumptions and I will try out this process.

You created a list in SharePoint on a site.  You saved that list as a template (without content?).  Moved the template to another site. Created a list on that site from the template.  Went to the list and attempted to customize the forms in PowerApps - It failed (red X's). You created a new list (on that same site) from the same template. Went to the list and attempted to customize the forms in PowerApps - it works.

Let me know if I assumed everything else correctly or if there are some corrections or additional bits of information.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Cbeene Helper I
Helper I

Re: SharePoint List Custom Form - Multiple Errors

You are mostly correct.  The only thing I would add is:

Within my first list, before creating any template but AFTER content was in my list, I tried creating a custom PA form and it contians the errors.  This is what lead me to creating said template (without content) and the two additional list.  Also, there is still no content in the two additional list at this time.  

Super User
Super User

Re: SharePoint List Custom Form - Multiple Errors

@Cbeene 

Okay...so:

Original Site has a List with content.  Attempted to customize forms in PowerApp and errors exist.

Created Template

Second Site - created list from template.  No data.  Customize forms - contains errors

Second Site - created yet another list from template. No data. Customize forms - no errors

 

Sound right now??  

If so, then I would actually start from trying to determine the issue on the Original site.  That seems to be where the issues started.  Have you looked over that any, or have you been focused on the other site lists?

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.
Cbeene Helper I
Helper I

Re: SharePoint List Custom Form - Multiple Errors

Correct Randy.

I am focused on the original site and have made all changes/suggestions to said site.  I just wanted everyone to be aware of my testing and results.  

Super User
Super User

Re: SharePoint List Custom Form - Multiple Errors

@Cbeene 

Okay great!  Then yes, let's focus on the original site and the issues there.  I was leaning torward an issue with the template, but now I see this is really all the way back to the original list...so, I'll not focus on that.

 

Back to the original - please review these and fill in any details missing or corrections:

1) You've verified your datasource has no errors showing.

2) You've removed your datasource completly and added it back in - still errors.

3) You've tried to insert a new screen in your app and insert a new EditForm on it based on the DataSource and it shows errors

4) You have all access to the original list and there are no permissions or other issues at play

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up. Solved your problem? - Click on Accept as Solution. Others seeking the same answers will be happy you did.

Helpful resources

Announcements
MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Apps Community!

Power Platform 2020 release wave 1 plan

Power Platform 2020 release wave 1 plan

Features releasing from April 2020 through September 2020

Top Solution Authors
Top Kudoed Authors
Users online (7,078)