cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Ela_Hsn
Helper I
Helper I

SharePoint List Edit Form not showing record patched from a gallery

Hi Experts,

 

I'm very new to using PowerApps, so I've customized an SP List Form using Powerapps, added a collection to collect multiple entries in one single form that I show using a gallery & then I patched those values to my SP List.

 

The issue I'm encountering now is that, when I click on a record on my SP list (or Item) the form comes up blank with no values in other words it doesn't list the record that I've clicked on's details. Please refer to my attached screenshots.

 

Also, I'm using a MS Flow to get approval on these items but the link I use also shows the edit form blank.

 

I'd appreciate your help on this.

 

4 REPLIES 4
C-Papa
Super User
Super User

Hi, have you tried changing the default display mode of the form to DisplayMode.New / DisplayMode.Edit? Also, the Item property of the form needs to be either the GalleryName.Selected or set as a variable. 

Hi,

 

Please refer to the below screenshots

C-Papa
Super User
Super User

in your second image, press the button show in a red circle and it should display a table containing the record. the table should only contain 1 row. If this does contain a record then the issue is with the Form somewhere. Just to be sure, is there already data in your SharePoint list? otherwise both answers would be blank. 

 

CPapa_0-1653495211158.png

 

Hi, so it shows a record.

Helpful resources

Announcements
Ignite 2022

WHAT’S NEXT AT MICROSOFT IGNITE 2022

Explore the latest innovations, learn from product experts and partners, level up your skillset, and create connections from around the world.

Power Apps Africa Challenge 2022

Power Apps Africa Challenge

Your chance to join an engaging competition of Power Platform enthusiasts.

Users online (1,577)