cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Rg4963 Helper II
Helper II

SharePoint List not updating after you click submit

Hey,

 

I made a PowerApps form and but it on a SharePoint page. When entering information on the form when clicking the submit button the information suppose to go to the SharePoint list but for some reason it's not please help !

 

this is what I have in the save bouton part

 

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: SharePoint List not updating after you click submit

@Rg4963 

You might want to review this past forum post for a similar problem.  There are several ideas here you can try.

 

Link to relevant post:

https://powerusers.microsoft.com/t5/Building-Power-Apps-Formerly/There-was-a-problem-saving-your-cha...

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

View solution in original post

3 REPLIES 3
Super User
Super User

Re: SharePoint List not updating after you click submit

@Rg4963 

I would appreciate if you could answer the following 2 questions:

 

#1. Does your form submit properly when you test it in PowerApps Studio as opposed to on the Sharepoint page?  If yes, the problem has something to do with the SP integration.

 

#2. What is the DefaultMode property of your Form?  Please try changing it to FormMode.New.

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

 

 

Highlighted
Rg4963 Helper II
Helper II

Re: SharePoint List not updating after you click submit

It works but doesn't go to the SharePoint list. My PowerApps form is on a actual SharePoint page.

 

So when they click submit I need information to go back to the list so I can view.

Super User
Super User

Re: SharePoint List not updating after you click submit

@Rg4963 

You might want to review this past forum post for a similar problem.  There are several ideas here you can try.

 

Link to relevant post:

https://powerusers.microsoft.com/t5/Building-Power-Apps-Formerly/There-was-a-problem-saving-your-cha...

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

View solution in original post

Helpful resources

Announcements
MBAS Gallery 2020

MBAS Gallery 2020

Watch Microsoft Business Applications Summit sessions on-demand.

firstImage

New Ranks and Rank Icons released on April 21!

The time has come: We are finally able to share more details on the brand-new ranks coming to the Power Apps Community!

Top Solution Authors
Top Kudoed Authors
Users online (7,832)