cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Rg4963
Level: Powered On

SharePoint List not updating after you click submit

Hey,

 

I made a PowerApps form and but it on a SharePoint page. When entering information on the form when clicking the submit button the information suppose to go to the SharePoint list but for some reason it's not please help !

 

this is what I have in the save bouton part

 

1 ACCEPTED SOLUTION

Accepted Solutions
Super User
Super User

Re: SharePoint List not updating after you click submit

@Rg4963 

You might want to review this past forum post for a similar problem.  There are several ideas here you can try.

 

Link to relevant post:

https://powerusers.microsoft.com/t5/Building-Power-Apps-Formerly/There-was-a-problem-saving-your-cha...

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

View solution in original post

3 REPLIES 3
Super User
Super User

Re: SharePoint List not updating after you click submit

@Rg4963 

I would appreciate if you could answer the following 2 questions:

 

#1. Does your form submit properly when you test it in PowerApps Studio as opposed to on the Sharepoint page?  If yes, the problem has something to do with the SP integration.

 

#2. What is the DefaultMode property of your Form?  Please try changing it to FormMode.New.

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

 

 

Rg4963
Level: Powered On

Re: SharePoint List not updating after you click submit

It works but doesn't go to the SharePoint list. My PowerApps form is on a actual SharePoint page.

 

So when they click submit I need information to go back to the list so I can view.

Super User
Super User

Re: SharePoint List not updating after you click submit

@Rg4963 

You might want to review this past forum post for a similar problem.  There are several ideas here you can try.

 

Link to relevant post:

https://powerusers.microsoft.com/t5/Building-Power-Apps-Formerly/There-was-a-problem-saving-your-cha...

 

---
Please click "Accept as Solution" if my post answered your question so that others may find it more quickly. If you found this post helpful consider giving it a "Thumbs Up."

View solution in original post

Helpful resources

Announcements
Better Together’ Contest Finalists Announced!

'Better Together’ Contest Finalists Announced!

Congrats to the finalists of our ‘Better Together’-themed T-shirt design contest! Click for the top entries.

thirdimage

Power Apps Community User Group Member Badge

Fill out a quick form to claim your user group badge now!

sixthImage

Join THE global Microsoft Power Platform event series

Attend for two days of expert-led learning and innovation on topics like AI and Analytics, powered by Dynamic Communities

Power Platform 2019 release wave 2 plan

Power Platform 2019 release wave 2 plan

Features releasing from October 2019 through March 2020

thirdimage

Microsoft Business Applications Virtual Launch

Join us for the Microsoft Business Applications Virtual Launch Event on Thursday, April 2, 2020, at 8:00 AM PST.

thirdimage

Community Summit North America

Innovate, Collaborate, Grow - The top training and networking event across the globe for Microsoft Business Applications

Top Solution Authors
Top Kudoed Authors
Users online (10,420)