cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

SharePoint Person field does not return any values on search

I have a PowerApp with a SharePoint list as the data source. In that list there are a handful of "People or Group" columns which require the user to select someone within the company who will fulfill that role on the project.

 

When creating a new entry, I don't run into any issues searching any of those fields and selecting a user. However, when editing an existing entry, the form often doesn't return anything - you can type in someone's name, and no suggestions will appear, which prevents you from selecting a valid user. The app doesn't do this for every person field; some of them will return search results, and others will remain blank, and it varies which ones are working each time I test it.

 

As a side note - I also have this issue on a couple of choice fields. These fields just list a handful of choices, but if someone wants to change the original choice in the Edit form, the full list of choices does not appear.

 

I have a command to Refresh('Data Source') for the screen OnVisible property, but that doesn't seem to have really made a difference.

 

Is there anything else I can try to get these fields working?

1 ACCEPTED SOLUTION

Accepted Solutions
Community Support
Community Support

Hi @cassandra ,

 

Do you mean your Person column in your PowerApps when you search some users' name it shows blank?

I test that on my side(both use allow multiple and not allow mutiple person type to test) and it works well.Could you please share more details of your controls of your Person column in your App?

Firstly, could you please check whether these users in your O365 group?When you want to use Person type to search you should add your user as next:

20190403admincenter.PNG

And if all users are be added, could you please try to change the display and search to display name as next and then test?

20190403persontest.PNG

 

Hope this could be helpful.

 

Best Regards.

Yumia

 

 

View solution in original post

1 REPLY 1
Community Support
Community Support

Hi @cassandra ,

 

Do you mean your Person column in your PowerApps when you search some users' name it shows blank?

I test that on my side(both use allow multiple and not allow mutiple person type to test) and it works well.Could you please share more details of your controls of your Person column in your App?

Firstly, could you please check whether these users in your O365 group?When you want to use Person type to search you should add your user as next:

20190403admincenter.PNG

And if all users are be added, could you please try to change the display and search to display name as next and then test?

20190403persontest.PNG

 

Hope this could be helpful.

 

Best Regards.

Yumia

 

 

View solution in original post

Helpful resources

Announcements
News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

Power Apps Community Call

Power Apps Community Call- January

Check out the Power Apps Community Call for January 2021

PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

Top Solution Authors
Top Kudoed Authors
Users online (5,309)