cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Regular Visitor

SharePoint form with attachment control not submitting attachments on Android

Recently we have issues with Android devices where attachments are not going through to SharePoint when they are selected from the devices files/folders - this is when users are adding photos from their library.
We are using a SharePoint form with attachment control.

We have tried functions Patch and SubmitForm and neither are working.

This issue does not occur on iOS.

2 ACCEPTED SOLUTIONS

Accepted Solutions
Highlighted
Microsoft
Microsoft

Re: SharePoint form with attachment control not submitting attachments on Android

HI @Em1ly ,

 

Do you have any error message that the application provided when attempting to pass the attachments to SharePoint? How are you using the Patch and SubmitForm functions?

 

Depending on the error/issue it could be useful to open a ticket to Microsoft Support through here: https://admin.powerplatform.microsoft.com/support in order to Troubleshoot your issue in more depth.

 

Additionally you have here documentation for SubmitForm and for the Patch function. This has information on how the functions work and their syntax, which could be helpful to identify what is going on.

 

Hope this helps!

 

Regards,

Ricardo

View solution in original post

Highlighted
Regular Visitor

Re: SharePoint form with attachment control not submitting attachments on Android

Hi, thanks for the response.

 

In the end it came down to needing to turn off the setting option "optimise images for upload". 
We are still unsure of the background changes to this setting and why its only just affected the apps but this has solved this issue none the less. 

View solution in original post

2 REPLIES 2
Highlighted
Microsoft
Microsoft

Re: SharePoint form with attachment control not submitting attachments on Android

HI @Em1ly ,

 

Do you have any error message that the application provided when attempting to pass the attachments to SharePoint? How are you using the Patch and SubmitForm functions?

 

Depending on the error/issue it could be useful to open a ticket to Microsoft Support through here: https://admin.powerplatform.microsoft.com/support in order to Troubleshoot your issue in more depth.

 

Additionally you have here documentation for SubmitForm and for the Patch function. This has information on how the functions work and their syntax, which could be helpful to identify what is going on.

 

Hope this helps!

 

Regards,

Ricardo

View solution in original post

Highlighted
Regular Visitor

Re: SharePoint form with attachment control not submitting attachments on Android

Hi, thanks for the response.

 

In the end it came down to needing to turn off the setting option "optimise images for upload". 
We are still unsure of the background changes to this setting and why its only just affected the apps but this has solved this issue none the less. 

View solution in original post

Helpful resources

Announcements
secondImage

Demo-Extravaganza 2020

Check out these cool Power Apps & vote on your favorite!

secondImage

Community Highlights

Check out whats happening in Power Apps

secondImage

Community User Group Member Badges

FIll out a quick form to claim your community user group member badge today!

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (9,860)