cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
BMurman
Frequent Visitor

SharePoint image not showing in Image Control for some users

Hello,

 

I created a Canvas Power App that will be used on a Desktop browser (so not on mobile). This app will be used by staff to view signatures of signatories within the organisation. The signatures are stored within a SharePoint document library.

 

The problem that we're having is that for some users the signature image is not showing. I have debugged this in a monitor to check if the images are correctly retrieved from SharePoint. I couldn't find any problems in the retrieval of the images. I also added a Label to the app to check if the URL of the image is present, this is also seems to work as expected.

 

All users that have reported this issue have access to the SharePoint document library that contains the signature images with Read+write permissions. They are able to view these images on the SharePoint document library but not in the Power App.

 

I removed and re-added the SharePoint connection to the document library that contains the signatures but this also did not help.

 

Seeing that the signature is visible for most personnel but not visible for other leads me to believe the issue is not present within the Power App but somewhere else. I check with multiple users if they had set the browser setting "Show all images" to true. This was also the case so the problem shouldn't be cause by this setting. I also had one user delete all his cookies but this also did not resolve the problem.

 

For some users the image shows on one browser (Google Chrome) but not on the other (Edge Chromium), for other users this is reversed and the image is shown on Edge Chromium and not on Google Chrome.

 

I even looked in the browser console to check if I could see some errors but there is nothing out of the ordinary to be seen there.

 

I have absolutely no idea where to look further to resolve this issue and it is blocking the release of the Power App. My question is if somebody here know a trick or a setting that I overlooked that causes images to not be visible in a Canvas Power App.

 

Thanks in advance.

1 ACCEPTED SOLUTION

Accepted Solutions
BMurman
Frequent Visitor

I managed to find the solution. Power App did not correctly authenticate to SharePoint so SharePoint redirected Power Apps, but the Power Apps image control could not handle this redirect. I managed to solve this by displaying the Thumbnail property of the image instead of 'Link to item'.

View solution in original post

2 REPLIES 2
WarrenBelz
Super User
Super User

Hi @BMurman ,

Can  you please provide (in Text) the code you are using to display the images - also this blog of mine may be useful for the options available to you.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

Visit my blog Practical Power Apps

BMurman
Frequent Visitor

I managed to find the solution. Power App did not correctly authenticate to SharePoint so SharePoint redirected Power Apps, but the Power Apps image control could not handle this redirect. I managed to solve this by displaying the Thumbnail property of the image instead of 'Link to item'.

Helpful resources

Announcements
Microsoft 365 Conference – December 6-8, 2022

Microsoft 365 Conference – December 6-8, 2022

Join us in Las Vegas to experience community, incredible learning opportunities, and connections that will help grow skills, know-how, and more.

Top Solution Authors
Top Kudoed Authors
Users online (1,398)