cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
rtoapanta
Frequent Visitor

SharePoint list connection no refreshing

I got an app running on productive system.

I just added a new column in the sharepoint list.

Now in my web app editor, i cant refresch sharepoint list to take new column on my develop.

 

Then I erased this new column, but problem persist

Now i cant do anything about editing my app cause this error.

58 REPLIES 58
Anonymous
Not applicable

Still not working this morning. Look forward to update.

Still does not work for me.
Waiting for a solution.

Anonymous
Not applicable

I've also had an error message from Power BI saying it's not refreshing from SharePoint either.

 

And PowerApps is still not working...

I think it's working again. Each data source I refreshed was successfull (though I haven't modified the table to see if it's accepting changes to the datasource)

For me..  it is still not working.

erichylinski
Regular Visitor

I am able to refresh a list created today, but unable to refresh lists created prior to Friday

Edited to say, I can change the PowerApp to connect to a new SharePoint list, but if I update the list it's not updating in PowerApps. It looks like it's refreshing ok, but it's not, nothing happens. Still stuck...

v-xida-msft
Community Support
Community Support

Hi @rtoapanta,

 

I have made a test on my side and don't have the issue that you mentioned. 

 

Please take a try to click "Refresh" option under Data source to check if the issue is solved. 

 

In addition, as an alternative solution, you could also take a try to remove the SP list and then re-add it within your app, check if the data has been updated.

 

If you have solved your problem, please go ahead and click “Accept as Solution” so that this thread will be marked for other users to easily identify.

 

Best regards,

Kris

Community Support Team _ Kris Dai
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.

I have done refresh on both the datacard and the datasource, neither works. I have created a new SharePoint list, changed the data source in PowerApps to that, and the first connection is fine, but when I update the SharePoint list and add another column, PowerApps does not refresh and update the data, so the issue is still happening.

Hello all - we've completed the roll out to all regions to correct this issue. Please close PowerApps studio and reopen your app, and you should now be able to refresh datasources. This issue was caused by an update made last week, we will investigate its underlying cause and work to have testing in place to ensure it doesnt occur again.

 

Please reach out if you're still encountering problems, we're sorry for any inconvinience caused.

Thanks,
Clay.

Helpful resources

Announcements
Power Platform Conf 2022 768x460.jpg

Join us for Microsoft Power Platform Conference

The first Microsoft-sponsored Power Platform Conference is coming in September. 100+ speakers, 150+ sessions, and what's new and next for Power Platform.

Power Platform Call June 2022 768x460.png

Power Platform Community Call

Join us for the next call on June 15, 2022 at 8am PDT.

PA Virtual Workshop Carousel 768x460.png

Register for a Free Workshop

This training provides practical hands-on experience in creating Power Apps solutions in a full-day of instructor-led App creation workshop.

PA.JPG

New Release Planning Portal (Preview)

Check out our new release planning portal, an interactive way to plan and prepare for upcoming features in Power Platform.

Top Solution Authors
Top Kudoed Authors
Users online (1,841)