cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

SharePoint list connection no refreshing

Hi,

Been relatively new to PowerApps, but made lots of progress thnks to this forum.  However, struggling to find the solution to my latest problem.

My app reads and writes data from the SharePoint list.  For the last week all worked perfectly reading and updating the data.

Then 2 days ago I had to delete some of my columns in the SharePoint list and added some new ones.

Since then, every time I start PowerApps it has little warning symbols for some fields which I changed, but the new fields I added are not available.  Similarly, when using the app on a mobile, the new data does not come through.

When I edit the app online and refresh the connection, everything gets updated, the warning symbols disappear, and the data from new columns comes through.  Unfortunately I can't seem to refresh the connection in the iOS app.

After having refreshed the connection, I have saved the app countless times, but when I open the app again the next time, it has lost the connection to the updated SharePoint list again...

I have tried to add Update(Source) to a button on the homepage of the app, but without any success.

Any other suggestions which would save me having to build the app again from scratch?

Many thanks in advance.

26 REPLIES 26

I did another test by removing the PowerApp I created and recreated it from SharePoint Online. My missing column did appear. I took this a step further and added another column to my list from SharePoint. I am still not able to sync a new column to the PowerApp.

 

Tried to refresh the data souce and waited for a while but it just has not appeared. I'm not sure if I am missing a step or if there is an issue. 

 

Weird.

Where are you waiting for it to appear?

 

Have you tried to see if the new field appears in your data panel for the form - https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/customize-forms-sharepoint

Hi sarafankit 

 

Thank you for your quick reply and link as well. Yes, clicking on the data pane I was able to see how I can make new columns visable. This link did explain that:

 

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/customize-forms-sharepoint

 

I appricate your quick assistance. This was a big help in understanding the behavior.

I wonder if somebody figure out a solution for this. I am facing an issue where I have to create new data source connection SharePoint list each time I update the list. Refresh doesn work at all.

@npatel- We had a regression in this area. The hotfix should go out by tomorrow. Sorry for the trouble.

 

For now, you are following the only workaround.

This still doesn't work, i just added a simple text column to my list, go into powerapps, refresh the data source and the new one i just added is NOT there. If i delete the data source and re add it, i have to RE DO all of variables and visible funtions. it's highly annoying to have to rebuild the form from SCRATCH each time. If i am missing something please let me know. 

 

i have tried the work around, i delete the data source, add it back, and all of the custom stuff i did such as data card sizes, their visibility on certain tabs, and more has to be re done again. 

This still seems to be a problem, however I have had no success with the previous work-arounds (repeated refreshing, breaking and replacing the connection to the sharepoint list, manually calling the column in a custom card). Has powerapps changed how it links with sharepoint and is there a new work-around?

 

thanks,

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Top Solution Authors
Top Kudoed Authors
Users online (106,035)