cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

SharePoint list connection no refreshing

I got an app running on productive system.

I just added a new column in the sharepoint list.

Now in my web app editor, i cant refresch sharepoint list to take new column on my develop.

 

Then I erased this new column, but problem persist

Now i cant do anything about editing my app cause this error.

58 REPLIES 58


@Eickhel wrote:
@stick97 wrote:

@Eickhel wrote:

Just wondering.... do you have any code in the OnStart?


I have code in OnStart, but the screen in the screenshot is not the start screen. There is just a refresh function in the OnVisible action for this screen, though, too.


I'm having issues if I have code in the OnStart.... could you please try to remove it to see if it works afterwards?


Removing the OnStart code didn't make any difference.

Very interesting! I have code in OnStart and I believe I have found the culprit for my form: 

Set(MyUPN,User().Email)

 

This has worked before, but it now keeps loading forever. If I remove that line, the form works again.

I guess it's a new bug?

 

In any case, great find, thanks!

Dear Staff,

 

Thank you for your help in this topic.

 

For me is working , now i can refresh my SP list, update my data and made some changes I needed

 

But the field I added doesnt appear when I want to use it into my develop.

 

Regards.

had similar code and works, try to erase and type again.

dont copy paste code


@LeAdam wrote:

Very interesting! I have code in OnStart and I believe I have found the culprit for my form: 

Set(MyUPN,User().Email)

 

This has worked before, but it now keeps loading forever. If I remove that line, the form works again.

I guess it's a new bug?

 

In any case, great find, thanks!


It's definitely a bug... it was working before.

Can you please let me know the resolution? for me refresh data source never complete??

Dude, this problem should be general, check comment on 3rd page.

 

Hi All - we are aware of this issue and our team is working on correcting it now - this is also being tracked at : https://powerusers.microsoft.com/t5/Connecting-to-Data/Data-Source-Unable-to-refresh-Try-again/m-p/1...

 

Microsoft Staff always are working on those kind of problems.

good luck !

Anonymous
Not applicable

I have tried closing and coming back in multiple times and my changes are still not showing 😞  I removed the datasource and reconnected and nothing!  I am at a loss for what else to do here.

Anonymous
Not applicable

well apparently it just took a long time.... my updates just showed.  How frustrating.

Helpful resources

Announcements
News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

Power Apps Community Call

Power Apps Community Call- January

Mark your calendars and join us for the next Power Apps Community Call on January 20th, 8a PST

PP Bootcamp Carousel

Global Power Platform Bootcamp

Dive into the Power Platform stack with hands-on sessions and labs, virtually delivered to you by experts and community leaders.

secondImage

Power Platform Community Conference On Demand

Watch Nick Doelman's session from the 2020 Power Platform Community Conference on demand!

Top Solution Authors
Top Kudoed Authors
Users online (4,436)