cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Frequent Visitor

Re: SharePoint list connection no refreshing

I did another test by removing the PowerApp I created and recreated it from SharePoint Online. My missing column did appear. I took this a step further and added another column to my list from SharePoint. I am still not able to sync a new column to the PowerApp.

 

Tried to refresh the data souce and waited for a while but it just has not appeared. I'm not sure if I am missing a step or if there is an issue. 

 

Weird.

Highlighted
Power Apps
Power Apps

Re: SharePoint list connection no refreshing

Where are you waiting for it to appear?

 

Have you tried to see if the new field appears in your data panel for the form - https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/customize-forms-sharepoint

Highlighted
Frequent Visitor

Re: SharePoint list connection no refreshing

Hi sarafankit 

 

Thank you for your quick reply and link as well. Yes, clicking on the data pane I was able to see how I can make new columns visable. This link did explain that:

 

https://docs.microsoft.com/en-us/powerapps/maker/canvas-apps/customize-forms-sharepoint

 

I appricate your quick assistance. This was a big help in understanding the behavior.

Highlighted
Regular Visitor

Re: SharePoint list connection no refreshing

I wonder if somebody figure out a solution for this. I am facing an issue where I have to create new data source connection SharePoint list each time I update the list. Refresh doesn work at all.

Highlighted
Power Apps
Power Apps

Re: SharePoint list connection no refreshing

@npatel- We had a regression in this area. The hotfix should go out by tomorrow. Sorry for the trouble.

 

For now, you are following the only workaround.

Highlighted
Regular Visitor

Re: SharePoint list connection no refreshing

This still doesn't work, i just added a simple text column to my list, go into powerapps, refresh the data source and the new one i just added is NOT there. If i delete the data source and re add it, i have to RE DO all of variables and visible funtions. it's highly annoying to have to rebuild the form from SCRATCH each time. If i am missing something please let me know. 

 

i have tried the work around, i delete the data source, add it back, and all of the custom stuff i did such as data card sizes, their visibility on certain tabs, and more has to be re done again. 

Highlighted
Regular Visitor

Re: SharePoint list connection no refreshing

This still seems to be a problem, however I have had no success with the previous work-arounds (repeated refreshing, breaking and replacing the connection to the sharepoint list, manually calling the column in a custom card). Has powerapps changed how it links with sharepoint and is there a new work-around?

 

thanks,

Helpful resources

Announcements
secondImage

New Return to Workplace

Reopen responsibly, monitor intelligently, and protect continuously with solutions for a safer work environment.

Experience what’s next for Power Apps

Join us for an in-depth look at the new Power Apps features and capabilities at the free Microsoft Business Applications Launch Event.

Check this Out

Helpful information

Featuring samples like Return to the Workplace and Emergency Response Applications

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Top Solution Authors
Top Kudoed Authors
Users online (1,755)