cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Dawid_Szwajca
New Member

SharePoint list not refreshed after saving PowerApp form

Hello,

I have got a small issue.

 

I have customized forms with PowerApps - New / Edit.

 

The New form basically works fine. However when I save the Edit form, the data on SharePoint list is not updated automatically. I have to refresh the page to see updated values on the edited row.

 

SharePointIntegration : OnSave

If(SharePointFormMode="CreateForm"; SubmitForm(Order_add_form); If(SharePointFormMode="EditForm"; SubmitForm(Order_edit_form)));; Refresh(Orders)

 

EditForm : OnSuccess

ResetForm(Order_edit_form);; RequestHide();; Refresh(Orders)

 

 

Could you help me?

5 REPLIES 5
Dawid_Szwajca
New Member

I found now that when I am using double groupped view (first and secondary grouping) then it doesn't update.

But when the view uses just one grouping, then it updates fine.

 

It may be a bug, then.

WarrenBelz
Super User III
Super User III

Hi @Dawid_Szwajca ,

The PowerApps form, although "integrated" into SharePoint is actually running as a separate "program" when launched and saves data back to SharePoint and then closes. Any refresh you do (I noticed this in your code) is in Power Apps and has absolutely no influence on what might happen on your SharePoint view - you have simply closed the Power Apps form. Having said that, SharePoint mostly refreshes to show the updated data, but there is nothing you can do in Power Apps to influence this.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

Thank you. I understand the point but it shouldn't behave that way anyway. Who can have a look on that and if needed report it so Microsoft can fix that?

@Dawid_Szwajca ,

I am a user like you (I do not work for Microsoft). You can raise a Support Ticket, however those are for things that are wrong with your apps in particular. You might also put this on the Ideas forum and someone may see it.

 

Please click Accept as solution if my post helped you solve your issue. This will help others find it more readily. It also closes the item. If the content was useful in other ways, please consider giving it Thumbs Up.

The problem happens in my instance when grouping on one field only.  If I remove the 'group by' setting in the SharePoint list view, the view refreshes when I save a record.

Helpful resources

Announcements
PA User Group

Welcome to the User Group Public Preview

Check out new user group experience and if you are a leader please create your group

Power Apps Community Call

Monthly Power Apps Community Call

Did you miss the call?? Check out the Power Apps Community Call here!

secondImage

Experience what’s next for Power Apps

See the latest Power Apps innovations, updates, and demos from the Microsoft Business Applications Launch Event.

Power Platform ISV STudio

Power Platform ISV Studio

ISV Studio is the go-to Power Platform destination for ISV’s to monitor & manage applications post-AppSource publish.

Top Solution Authors
Top Kudoed Authors
Users online (18,729)