cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Highlighted
Anonymous
Not applicable

SharePoint lists not working at OnStart

I have a PowerApp that loads User data (to check the role of the user in the powerapp) from a Sharepoint list at OnStart.
Last week it was working fine, but since yesterday, data won't load and the PowerApp won't receive any data.
Also, the Sharepoint list won't work at "OnTimerEnd" from timers.

 

I've tried updating the connection with sharepoint, I've checked the permissions in sharepoint lists, I've tried using collections, but none of them seems to work.

 

Thank you!

6 REPLIES 6
Highlighted
Helper II
Helper II

Hi mate,

 

If you create a brand new connection, can you access the SharePoint list data?

 

Also, can you try create a brand new app and access it too? Sometimes PowerApps will have authentication issues. I'm more than happy to take a closer look as well if you can provide me some access or details. Happy to do a teams meeting 🙂


Regards,

Jacob Shand | Automation Specialist

NextStep Creations


Taking your PowerApps Skill the NextStep

Highlighted
Anonymous
Not applicable

Hi,

Thank you for your answer
Creating a new connection didn't work and creating a new app didn't work either.
I also tried in other apps that I had previously created, and it didn't work there.

This is the result I get when I put a SharePoint list at OnStart
 
captura1.PNG
"_User" is a SharePoint list full of items, and it didn't find anything. I get "Didn't find any data" message every time in every app.
In other scenario, it find data, such as creating a Table or a Gallery.
It gives me the same message at OnTimerEnd of timers.

It only fails at OnStart and OnTimerEnd of timers

Highlighted

I see what might be your error.

 

In your ClearCollect function, you need to separate the collection and the data source using a comma.

 

Like so: ClearCollect(A, info_user)

 

Regards,

Jacob Shand | Automation Specialist

NextStep Creations


Taking your PowerApps Skill the NextStep

Highlighted
Anonymous
Not applicable

No, spanish version uses ";" instead of commas

I put ClearCollect, but it won't work with anything related to SharePoint lists.
captura2.PNG

Highlighted

My apologies, I use the English version.

 

You can ClearCollect from a SharePoint list. Can you show me where you are trying to ClearCollect and getting an error?

 

Highlighted
Anonymous
Not applicable

The SharePoint list contains information about users, like, Name, Mail, Role...

Im not getting an error anywhere, It just show the message I showed before ("Didn't find any data").

I just realized that at "OnVisible" it won't work either.

Helpful resources

Announcements
Community Conference

Power Platform Community Conference

Check out the on demand sessions that are available now!

News & Announcements

Community Blog

Stay up tp date on the latest blogs and activities in the community News & Announcements.

secondImage

Power Platform 2020 release wave 2 plan

Features releasing from October 2020 through March 2021

Community Highlights

Community Highlights

Check out the Power Platform Community Highlights

Top Solution Authors
Top Kudoed Authors
Users online (12,881)