cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Frequent Visitor

Sharepoint Form does not submit

Hello everyone,

 

I hope someone can help me with this issue.. 🙏

So I connected my sharepoint list (pretty big more than 500 entries) with my form. 

But everytime I run the app and try to submit some info, nothing happens.

(After submitting, you should be redirected to the first page).

When I used an excel sheet as data source, it functioned perfectly fine,

but now it does not and I cannot find what's causing this problem:(

 

Thank you in advance!

 

Sinchen_0-1611321892790.png

Formulas:

ICON: On Select ->  Submit(Form1) And Back()

FORM: On Success -> Navigate(NetworkPartnersList)

12 REPLIES 12
Super User II
Super User II

@Sinchen 

Sharepoint has a column called title that may be required. You can put it on a form and set its default property to “aaa” or something else then hide the card and see if the form submits. 

There should be nothing in the icon that submits the form but SubmitForm(Form1). Submit(Form1) is incorrect. 

Hey:)

Thank you for your fast reply😊

I just looked for the title column but its reused as the first column of my list (fyi i did not create the sharepoint list)

Sinchen_0-1611326942625.png ( title = NP No.) 

and it's part of my form (as you can see above)

 

I also did erase the 'And back()'-part in the ICON but sadly it did not solve my problem either 😞

 

Just trying to troubleshoot some common problems.  Check the name of the form and make sure it is the same in SubmitForm() function.

 

You should be able to add this to your Icon with your submit.

 

SubmitForm(Form1); Collect(SubmitErrors, Errors(YourDataSource))

 

Add a table to another screen and use Submit Errors as the data source.  Pull in the fields.   Then test your submit and check your table to see if any errors were captured.  It should tell you what the issue is.



If you like this post, give it a Thumbs up. If it answered your question, Mark it as a Solution to enable other users find it.
Frequent Visitor

Little update: I completely redid the app and there are no errors displayed. (I even double checked)

So in theory everything should work fine.

But the form still does not submit. 

Super User II
Super User II

@Sinchen 

To troubleshoot this issue, please go to make.powerapps.com and use PowerApps to create the app from your data and see if  data can be submitted. 

Did you do what I suggested and collect errors on submit?   Is this where you are not seeing any errors?

 



If you like this post, give it a Thumbs up. If it answered your question, Mark it as a Solution to enable other users find it.

I tried to but when I pasted the formula, you sent me it gave me an error message 😕

Can you share a screen shot with the error?



If you like this post, give it a Thumbs up. If it answered your question, Mark it as a Solution to enable other users find it.

Helpful resources

Announcements
New Badges

New Solution Badges!

Check out our new profile badges recognizing authored solutions!

New Power Super Users

Congratulations!

We are excited to announce the Power Apps Super Users!

Power Apps Community Call

Power Apps Community Call: February

Did you miss the call? Check out the Power Apps Community Call here.

Top Solution Authors
Top Kudoed Authors
Users online (77,350)