cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
FlatFish
Helper I
Helper I

Sharepoint only detecting one column in re-uploaded list

Hi everyone, 

 

I have a power app that is connected to multiple SharePoint lists and the list(s) get re-uploaded with the same headers and title of the list each quarter. This time, however, when this one specific list was uploaded into power apps it is only detecting one column which causes multiple errors throughout the power app. 

 

The column 'Bank_name' is utilized primarily throughout the power app, but is no longer detected/the intellisense does not detect any other columns except 'Account_completion'. 

 

Is there something wrong with the way it was uploaded to SharePoint or something else that is happening? It is only with this specific list. When the list is refreshed in Power apps it causes 206 errors in the formulas, but if I remove it and connect it again it goes back to 25. 

 

Any help would be greatly appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
RandyHayes
Super User
Super User

@FlatFish 

Make sure you are using the real name of the column.  If the column was created with some other name and then renamed, it will still retain its original name.

I would suggest going into your list settings for Q4_User_Entitlement and see that the "Bank_name" column is in the list of columns.  Then click on that column to view its settings.  Take a look at the end of the URL in the address bar of the browser - it sill show you the "real" name of the column.  That is what you will need.

 

I hope this is helpful for you.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

View solution in original post

4 REPLIES 4
FlatFish
Helper I
Helper I

I tested in a different power app and adding a dropdown and all of the columns are listed when choosing the value it depends on. The issue is with a GroupBy function where it says the column name 'Bank_name' does not exist

 

Below is the code for the GroupBy function, but nothing changed since last quarter and only this time with uploading the table is there an issue

GroupBy(
    Filter(
        Q4_User_Entitlement,
        field_11 = UserName_Email.Text And field_1 = Gallery1.Selected.Result And field_29 = "not_completed" And field_12 = "Active"
    ),
    "Bank_name",
    "Group",
    "Account_Completion"
)

 

RandyHayes
Super User
Super User

@FlatFish 

Make sure you are using the real name of the column.  If the column was created with some other name and then renamed, it will still retain its original name.

I would suggest going into your list settings for Q4_User_Entitlement and see that the "Bank_name" column is in the list of columns.  Then click on that column to view its settings.  Take a look at the end of the URL in the address bar of the browser - it sill show you the "real" name of the column.  That is what you will need.

 

I hope this is helpful for you.

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

View solution in original post

Thank you for the response! I was able to figure that out and got it working correctly right as you sent it haha. I didn't know about checking it in the URL and that ensured it was accurate for me. I learned something new.

 

The only question I have is why all of a sudden did it require "field_2" instead of "Bank_name" when in the past it didn't require the change? Just curious if you know by chance!

RandyHayes
Super User
Super User

@FlatFish 

Good that you discovered that and learned something new!

One thing to keep in mind with "real" names and "renamed/display" names...SOME functions in PowerApps will honor both the renamed/display name and the real name, there are SOME functions in PowerApps that will only accept the "real" name.

 

As for the remaining question - well, since the field name is set at create time, the question would be - how are you creating the list?  It seems that something must have changed there!?

_____________________________________________________________________________________
Digging it? - Click on the Thumbs Up below. Solved your problem? - Click on Accept as Solution below. Others seeking the same answers will be happy you did.
Check out my PowerApps Videos too! And, follow me on Twitter @RandyHayes

Really want to show your appreciation? Buy Me A Cup Of Coffee!

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (2,961)