cancel
Showing results for 
Search instead for 
Did you mean: 
Reply
Anonymous
Not applicable

Show Image in Gallery

Hi all, I have a problem when I try to show image from Sharepoint online list in Gallery. In sharepoint list, I have a column with "Multiple lines of text" type. The value of that field is "appres://blobmanager/a615c9eb4b374aa39cb9d061b471bc17/3". I got that value from PowerApp AddImage control by get AddMediaWithImage.Media value. But, when I display it in another screen, it show nothing. I tried to change value to base 64 like "data:image/jpeg;base64,/9j/4AAQ..." but, I still show nothing. I read many acticle and follow it, but still not success. 

 

How can I display the value of that column as Image in PowerApp? Please help.

Many thanks.

 

Vincent

1 ACCEPTED SOLUTION

Accepted Solutions
Anonymous
Not applicable

Thank you all for your supporting. I solved my problem. My problem is : In sharepoint list, the type of picture column is "Multiple lines of text" and, you must select "Plain Text" instead of "Rich Text" or "Enhance Rich Text", because, when you get value and show in PowerApp, it will attach some HTML code, so PowerApp can't display a image. 

 

Thank you all.

Vincent

View solution in original post

6 REPLIES 6
Scobie
Advocate II
Advocate II

Hey @Anonymous,

 

If you are using a gallery in PowerApps put an image into your galley and set its default property to '{Link}'. Took me a while to find that.

v-micsh-msft
Community Support
Community Support

Hi @Anonymous,

 

The saved value for the image from AddMediaWithImage.Media  will not work once the App is closed.

The blobmanager://XXXXX is an PowerApps internal relative path for the current App session. once it is closed, the path will not be valid.

 

There are blogs talking about how to save this kind of image data through Microsoft Flow:

See this one for example:

The simplest No-Code solution to Save Picture Files from PowerApps to Flow

 

Regards,

Michael

Community Support Team _ Michael Shao
If this post helps, then please consider Accept it as the solution to help the other members find it more quickly.
Mike8
Memorable Member
Memorable Member

Hello @Anonymous ,

You can try to replace "data:image/jpeg;base64,/9j/4AAQ..." with "data:image/jpeg;base64,/9j/4AAQ..."  


Anonymous
Not applicable

Thank you all for your supporting. I solved my problem. My problem is : In sharepoint list, the type of picture column is "Multiple lines of text" and, you must select "Plain Text" instead of "Rich Text" or "Enhance Rich Text", because, when you get value and show in PowerApp, it will attach some HTML code, so PowerApp can't display a image. 

 

Thank you all.

Vincent

View solution in original post

Anonymous
Not applicable

Could you please show me the formula you used in the image to display the picture? I am having the same problem and I have that blob link saved as plain text in SP but nothing is displaying in my image control. Thank you

I have the same problem.  Please share the solution if you can.

Helpful resources

Announcements
2022 Release Wave 1 760x460.png

2022 Release Wave 1 Plan

Power Platform release plan for the 2022 release wave 1 describes all new features releasing from April 2022 through September 2022.

User Group Leader Meeting January 768x460.png

Calling all User Group Leaders!

Don't miss the User Group Leader meetings on January, 24th & 25th, 2022.

Community Connections 768x460.jpg

Community & How To Videos

Check out the new Power Platform Community Connections gallery!

Top Solution Authors
Top Kudoed Authors
Users online (1,681)